Bug 142280 - Graphical glitch when resizing column on Mac HiDPI display
Summary: Graphical glitch when resizing column on Mac HiDPI display
Status: RESOLVED DUPLICATE of bug 142061
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-14 12:22 UTC by Chris Shaw
Modified: 2021-05-14 22:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of column being resized (192.59 KB, image/png)
2021-05-14 12:22 UTC, Chris Shaw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Shaw 2021-05-14 12:22:06 UTC
Description:
When resizing a column in Calc on a Mac Retina display, the display glitches badly. Doesn't happen if the app is run in "Low Resolution" mode

Steps to Reproduce:
1.Create new Calc sheet
2.Drag bar between columns to resize the column


Actual Results:
Column of graphics glitches appear as column is resized

Expected Results:
Vertical black line should track mouse movement to give preview of new column width


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.1.3.2 / LibreOffice Community
Build ID: 47f78053abe362b9384784d31a6e56f8511eb1c1
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded
Comment 1 Chris Shaw 2021-05-14 12:22:35 UTC
Created attachment 171996 [details]
Screenshot of column being resized
Comment 2 steve 2021-05-14 22:25:19 UTC
Thanks for the report. Already filed as #142061 so setting to dupe.

*** This bug has been marked as a duplicate of bug 142061 ***