Bug 142287 - Writer Styles Most Recently Used Dropdown Would be Super
Summary: Writer Styles Most Recently Used Dropdown Would be Super
Status: RESOLVED DUPLICATE of bug 93111
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-14 16:22 UTC by sstory
Modified: 2021-05-30 04:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Mock screenhot (70.48 KB, image/png)
2021-05-14 16:23 UTC, sstory
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sstory 2021-05-14 16:22:16 UTC
Description:
It would be super, in Writer, if in the Paragraph and Character styles windows on the sidebar, there was a Most Recently Used Style dropdown, or a way to mark and unmark favorite styles that would then appear in that list of 10. 

I find when writing a long document--currently 100 pages--that I am often scrolling to the top and bottom to find the style with a lot I don't need at the time but don't want to delete. Having such a dropdown would be a nice improvement and time saver.

I am going to attach a screenshot of what the dropdown might look like.

Another option would be to allow a person to easily mark each style they are working with, tagging them so to speak, with a heart or star symbol showing beside them as a favorite, and using the dropdown at the bottom that says "All Styles" to have an option of "Favorite Styles".

I am not sure which implementation would be better.

Favorites should be able to be easily changed from the styles list as tagged or untagged.

Actual Results:
(This is a request for new feature, see description please)

Expected Results:
(This is a request for new feature, see description please)


Reproducible: Always


User Profile Reset: No



Additional Info:
(This is a request for new feature, see description please)
Comment 1 sstory 2021-05-14 16:23:26 UTC
Created attachment 172002 [details]
Mock screenhot

This is a mock screenshot of the dropdown implementation.

The other idea might also work.
Comment 2 Dieter 2021-05-30 04:50:10 UTC
Sstory, thank you for our ideas. Screenshot shows "All Styles". You can also change to "Applied Styles".

Similar ideas in bug 93111 => Duplicate

*** This bug has been marked as a duplicate of bug 93111 ***