Bug 142295 - Indistinct 'savemodified' in Colibre
Summary: Indistinct 'savemodified' in Colibre
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.3.0 target:7.2.2
Keywords:
Depends on:
Blocks: Icon-Theme-Colibre
  Show dependency treegraph
 
Reported: 2021-05-15 13:37 UTC by Dave Gilbert
Modified: 2021-09-04 19:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A modified savemodified_large.svg with a red 'label' (2.52 KB, image/svg+xml)
2021-05-15 13:37 UTC, Dave Gilbert
Details
A star as Galaxy (59.81 KB, image/png)
2021-05-15 17:24 UTC, Rizal Muttaqin
Details
A floppy with the red dot moved up over the label. (2.06 KB, image/svg+xml)
2021-05-15 18:07 UTC, Dave Gilbert
Details
The indicator on the top of the disk (16.39 KB, image/png)
2021-05-15 22:29 UTC, Rizal Muttaqin
Details
Where we should place the indicator? in top or bottom? (34.46 KB, image/png)
2021-05-16 07:59 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Gilbert 2021-05-15 13:37:35 UTC
Created attachment 172022 [details]
A modified savemodified_large.svg with a red 'label'

My father commented to me that he found the save modified icon in Colibre indistinct; the red blob seems less distinct than the bright star on older icon themes.
Trying it out, I wonder about making the 'label' red as well; it seems a small change but gives more contrast between the unmodified version.
Here's my attempt at modifying savemodified_large.svg
Comment 1 Rizal Muttaqin 2021-05-15 17:24:30 UTC
Created attachment 172030 [details]
A star as Galaxy

(In reply to Dave Gilbert from comment #0)
> Created attachment 172022 [details]
> A modified savemodified_large.svg with a red 'label'
> 
> My father commented to me that he found the save modified icon in Colibre
> indistinct; the red blob seems less distinct than the bright star on older
> icon themes.
> Trying it out, I wonder about making the 'label' red as well; it seems a
> small change but gives more contrast between the unmodified version.
> Here's my attempt at modifying savemodified_large.svg

Hi Dave
Thanks for the report!

I assume the older icon theme was Galaxy. Its save modified state clearly has bigger size. I am not sure it wpuld be great if the floppy disk label turn to be red. How about similar Galaxy approach? Colibre already has similar bright star, see New Slide icons in Impress' standard toolbar.
Comment 2 Rizal Muttaqin 2021-05-15 17:26:25 UTC
See the attachment(In reply to Rizal Muttaqin from comment #1)
> Created attachment 172030 [details]
> A star as Galaxy
> 

See the attachment. If you ask me to enlarge the star, I am afraid I can not do that since the star already use in some icons also. So, I have to update all of them.

Another solution may be enlarge the red dot?
Comment 3 Dave Gilbert 2021-05-15 18:06:33 UTC
Thanks; the star might work, but I think you're losing contrast because it's over the background grey and the midtone of the disk (and it is smaller than the old one).
Perhaps moving it up over the label would help to get the contrast against the white of the label.
I also tried moving the dot up over the label.
Comment 4 Dave Gilbert 2021-05-15 18:07:09 UTC
Created attachment 172032 [details]
A floppy with the red dot moved up over the label.
Comment 5 Rizal Muttaqin 2021-05-15 22:29:46 UTC
Created attachment 172039 [details]
The indicator on the top of the disk

(In reply to Dave Gilbert from comment #3)

> Perhaps moving it up over the label would help to get the contrast against
> the white of the label.
.

Here I move up the indicator and change a little bit the color so it has different red tone between outer and fill.
Comment 6 Dave Gilbert 2021-05-16 00:53:24 UTC
Thanks; that does look better to me; probably a little bigger might help more; but not bad!
Comment 7 Rizal Muttaqin 2021-05-16 07:59:53 UTC
Created attachment 172054 [details]
Where we should place the indicator? in top or bottom?

I agree that put the indicator above white area would increase the contrast, unfortunately it bring a drawback also: it looks unbalance. I prefer to keep the red indicator in bottom to keep the balance, but sacrifice a little bit the contrast.
Comment 8 Rizal Muttaqin 2021-05-16 08:00:27 UTC
oh and the indicator now bigger as your request.
Comment 9 Dave Gilbert 2021-05-16 16:50:04 UTC
It might be worth the unbalance if it keeps the contrast though;  my dad doesn't have any particular sight problems and complained about it, so I don't know about anyone who does have issues.
Anyway, increasing the size also helps; but any improvement is welcome.

Although my big red label might be over the top; I think it's probably OK to find a way to use the label area a bit; it's got the contrast and is otherwise empty; and anyway you expect to make notes on your disk labels!
Comment 10 Roman Kuznetsov 2021-05-30 19:45:56 UTC
Set to NEW if Rizal agrees with this "problem"
Comment 11 Commit Notification 2021-09-04 10:52:21 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/21c3894c5cc30e511429df89edd59f413d93550a

Colibre: tdf#142295 clear up unsaved state icons

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2021-09-04 19:16:38 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/7442aad7d992fe217cab0f558e17211b3907731b

Colibre: tdf#142295 clear up unsaved state icons

It will be available in 7.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.