Bug 142313 - Bad import of OOXML documents related to tdf#136841 on macOS
Summary: Bad import of OOXML documents related to tdf#136841 on macOS
Status: RESOLVED DUPLICATE of bug 142061
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All macOS (All)
: medium normal
Assignee: Thorsten Wagner
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-16 12:28 UTC by Thorsten Wagner
Modified: 2021-05-19 13:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample document (15.33 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-05-16 12:29 UTC, Thorsten Wagner
Details
EMF file extracted from the docx (29.10 KB, image/x-emf)
2021-05-16 13:05 UTC, Valek Filippov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Wagner 2021-05-16 12:28:29 UTC
Description:
Since support of retina graphics on macOS OOXML documents related to tdf#136841 are no longer imported correctly (see comments on https://gerrit.libreoffice.org/c/core/+/109072).

Steps to Reproduce:
1. Start LO with retina display active
2. Open sample OOXML document sw/qa/extras/ooxmlexport/data/tdf136841.docx

Actual Results:
Green square without document page background

Expected Results:
Document with single red left arrow


Reproducible: Always


User Profile Reset: No



Additional Info:
Issue exists if one retina display is active at least. Without retina displays (e.g. laptop external non-retina display and lid closed) issue do not exist. Cause is retina graphics support which becomes active if one retina display is active at least (e.g. laptop with lid open).
Comment 1 Thorsten Wagner 2021-05-16 12:29:00 UTC
Created attachment 172057 [details]
Sample document
Comment 2 Valek Filippov 2021-05-16 13:05:47 UTC
Created attachment 172059 [details]
EMF file extracted from the docx

The file imitates gradient fill by drawing 160 polygons with slightly changed coordinates and color. There are also few EMF+ records (no drawing, only set states).
Comment 3 Thorsten Wagner 2021-05-19 13:02:30 UTC
Issue seems to be caused by missing scaling operations for XOR emulation. These will be added in scope of tdf#142061. Patch is under preparation.

I will mark this ticket as duplicate of tdf#142061. Further work takes there.
Comment 4 Thorsten Wagner 2021-05-19 13:03:04 UTC

*** This bug has been marked as a duplicate of bug 142061 ***