Bug 142400 - Tabbed UI broken on very large 4k screen (21:9 aspect ratio. 3440x1440)
Summary: Tabbed UI broken on very large 4k screen (21:9 aspect ratio. 3440x1440)
Status: RESOLVED DUPLICATE of bug 131023
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.2.2 release
Hardware: ARM macOS (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-20 14:31 UTC by Bertrand Presles
Modified: 2021-05-21 11:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of LibreOffice window showing the reported bug (233.40 KB, image/jpeg)
2021-05-20 14:31 UTC, Bertrand Presles
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bertrand Presles 2021-05-20 14:31:18 UTC
Created attachment 172209 [details]
Screenshot of LibreOffice window showing the reported bug

On very large screens, the toolbar of tabbed UI have strange behaviors on its left. The background is greyish and where mouse overing elements they stay visibility selected (see screenshot).


Steps to repoduce:

- Connect a 4k screen capable of using 3440x1440 resolution or higher to a Mac.
- Launch LibreOffice (in my case LibreOffice Vanilla from the Mac AppStore)
- Select Tabbed UI User Interface option
- Maximize the window.

Expected behavior:

The tabbed toolbar is consistent and behave equally on the whole width of the window, even on very large screens
Comment 1 Julien Nabet 2021-05-20 15:02:08 UTC
Could you give a try at official LO 7.1.3 from https://www.libreoffice.org/download/download/ ?
Vanilla is from MacStore so not sure if there are some changes compared with official version.

Also you can take a look at https://wiki.documentfoundation.org/QA/FirstSteps
Comment 2 Bertrand Presles 2021-05-20 15:15:41 UTC
Indeed with 7.1.3 x86_64 release from https://www.libreoffice.org/download/download/ it works.

As I mentionned in the Hardware settings, I'm using an Apple Silicon mac (Macbook Air). And I can't find any arm64/Apple Silicon/universal build on www.libreoffice.org.

But I tried to launch the Vanilla (AppStore) version using Rosetta (x86_64 translator) to see if it's related to the ARM64 build specifically. And I still reproduce it with Rosetta.

So it may be a bug only reproduces in (non exclusive or):

- 7.1.2.3 release (version of the current LibreOffice Vanilla on AppStore)
- LibreOffice Vanilla specific changes.

Btw I used same exact icon set on LibreOffice 7.1.3 from libreoffice.org and on LibreOffice Vanilla 7.1.2.3 from the AppStore, which is Sukapura.
Comment 3 V Stuart Foote 2021-05-20 16:40:41 UTC
Seems a dupe of bug 133311 for rendering on displays wider than 3000px
Comment 4 Julien Nabet 2021-05-20 17:09:27 UTC
(In reply to Bertrand Presles from comment #2)
> Indeed with 7.1.3 x86_64 release from
> https://www.libreoffice.org/download/download/ it works.

Great!

> 
> As I mentionned in the Hardware settings, I'm using an Apple Silicon mac
> (Macbook Air). And I can't find any arm64/Apple Silicon/universal build on
> www.libreoffice.org.
There's no Arm64 Mac OS LO release yet and don't know if there'll be one soon.

> 
> But I tried to launch the Vanilla (AppStore) version using Rosetta (x86_64
> translator) to see if it's related to the ARM64 build specifically. And I
> still reproduce it with Rosetta.
...
Ok seems specific to Vanilla (AppStore) release then
Comment 5 Julien Nabet 2021-05-20 17:17:57 UTC
(In reply to V Stuart Foote from comment #3)
> Seems a dupe of bug 133311 for rendering on displays wider than 3000px

I'm not sure since it seems specific to Vanilla here.

<digression>
Just some time ago when people talk about LO community release, I thought it was always from TDF, now I know it might also be from LO Vanilla Community release.

What a mess Apple brought here by using in the name of their release:
- "Vanilla" => it normally means an unpatched release from official sources
- "Community" => this word should apply only to community contributing to TDF version, not "Apple Community" or something

What just a plain Apple LibreOffice release. It'd be clear for everyone.

Just my personal opinion but I consider this like kindda of deception from AppleStore.</digression>
Comment 6 V Stuart Foote 2021-05-20 21:44:52 UTC
Is there a Tools -> Options -> Personalization 'Preinstalled themes' radio button selected?  If so it is a dupe of bug 131023
Comment 7 Bertrand Presles 2021-05-21 07:28:34 UTC
(In reply to V Stuart Foote from comment #6)
> Is there a Tools -> Options -> Personalization 'Preinstalled themes' radio
> button selected?  If so it is a dupe of bug 131023

Yes indeed there is the "Preinstalled themes" radio selected, and indeed if I select "Use default apparence, don't use themes" instead, there is no more issue :)

*** This bug has been marked as a duplicate of bug 131023 ***