Bug 142429 - [fileopen crash] Writer 7.2.0 alpha1's libmergedlo.so crashes on opening HTML document
Summary: [fileopen crash] Writer 7.2.0 alpha1's libmergedlo.so crashes on opening HTML...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: HTML-Import
  Show dependency treegraph
 
Reported: 2021-05-22 13:05 UTC by stragu
Modified: 2021-06-01 09:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
crash backtrace (181.79 KB, text/x-log)
2021-05-26 07:46 UTC, stragu
Details
strace log (2.18 MB, application/x-bzip)
2021-05-26 08:13 UTC, stragu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stragu 2021-05-22 13:05:54 UTC
Description:
HTML document from another bug report crashes the latest master build.

It does not crash 7.0.4 or 7.1

Steps to Reproduce:
1. Download attachment 163738 [details]
2. Open with LO Writer

Actual Results:
Writer crashes

Expected Results:
Writer open the file without crashing, like two previous branches.


Reproducible: Always


User Profile Reset: No



Additional Info:
Crash report: https://crashreport.libreoffice.org/stats/crash_details/8d7d62f5-7fb1-432e-a0fa-5038f4c5044c

I don't believe another bug described the same issue.

Version used:

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: e9da22d3308557640e0edc45f72b1897f016d19b
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-05-21_07:07:00
Calc: threaded
Comment 1 Roman Kuznetsov 2021-05-22 17:37:27 UTC
no repro in

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: 128f67e0efa02294205a1abe1be874557ecdcecd
CPU threads: 4; OS: Linux 5.5; UI render: default; VCL: kf5 (cairo+xcb)
Locale: ru-RU (ru_RU.UTF-8); UI: ru-RU
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-05-19_06:21:05
Calc: threaded

possibly regression from last two days or just GTK3?

Can you try reset your user profile? Use Help-Restart in Safe mode for it
Comment 2 V Stuart Foote 2021-05-22 19:29:15 UTC
No crash on Windows builds of current 7.2.0 alpha+ master. Opens into Writer/Web in Web view. Can change to Normal view, or HTML view without issue.

=-testing-=
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 4a9eef7849a75ba91806886ea9c96d114c8d56f9
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 3 stragu 2021-05-23 14:07:14 UTC
Thanks Roman and Stuart

I have reset my user profile and still get the same crash with this HTML file.

Just tested with the latest master build to double-check, and I have the same issue:

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: 4a9eef7849a75ba91806886ea9c96d114c8d56f9
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-05-22_06:45:25
Calc: threaded
Comment 4 V Stuart Foote 2021-05-23 14:59:48 UTC
Next step would be to build or set-up for gdb debug [1] and download a nightly dbg build and try to get a back trace snd strace log of the crash. The crash report submissions for master builds don't have the useful symbols linked yet that are needed to tease out the offending calls. To move this along would need you to post up the gdb logs. 

=-ref-=
[1] https://wiki.documentfoundation.org/QA/BugReport/Debug_Information
Comment 5 stragu 2021-05-26 07:46:41 UTC
Created attachment 172344 [details]
crash backtrace

Here is the backtrace log as requested.
Comment 6 stragu 2021-05-26 08:13:15 UTC
Created attachment 172345 [details]
strace log

add strace.log as requested

Interestingly, starting LO with:

soffice --strace

... opened the file and I was able to scroll through the contents without a crash. Maybe expected? First time I produce an strace log.
Comment 7 Xisco Faulí 2021-05-31 14:30:22 UTC
I can't reproduce it in

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: f49e5902a3737c02fabf5bec23243ccb126426c4
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Stragu, still crashing with a recent daily build from this weekend ?
Comment 8 stragu 2021-06-01 09:46:44 UTC
Thanks everyone, it now opens without crashing with the daily from 2021-05-31:

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: e718f0e703c0fb33a0b1b5efe7b13b02c25f3335
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-05-30_21:49:59
Calc: threaded

Marking as WORKSFORME!