Bug 142518 - Inserting comment with RTL is not applied with DOCX
Summary: Inserting comment with RTL is not applied with DOCX
Status: RESOLVED DUPLICATE of bug 114734
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.5.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL RTL-UI
  Show dependency treegraph
 
Reported: 2021-05-27 04:53 UTC by Khalil
Modified: 2022-02-18 16:31 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Khalil 2021-05-27 04:53:18 UTC
Description:
Insert comment then change direction from LTR to RTL, then save file as DOCX, then close the file. Reopen it again the RTL in comment is not saved, it will be changed to RTL.
However ODT is  working fine.

Steps to Reproduce:
1.create new writer file and insert comment
2.add text in the comment and change direction to RTL then save it as DOCX
3.close the file and reopen it again.
4. the RTL in the comment text will be changed to LTR.

Actual Results:
The text direction in the comment changed to RTL instead of saving RTL direction.

Expected Results:
Keep direction as RTL after closing and reopen it again.


Reproducible: Always


User Profile Reset: No



Additional Info:
ODT extension the behavior is fine without issue.
Comment 1 Khalil 2021-05-27 04:59:47 UTC
Bug found also with LO 7.0.6
Comment 2 Gabor Kelemen (allotropia) 2021-05-27 16:28:39 UTC

*** This bug has been marked as a duplicate of bug 114734 ***