Bug 142578 - FILESAVE XLSX Filter by color overwrites conditional format background setting
Summary: FILESAVE XLSX Filter by color overwrites conditional format background setting
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.0.0 alpha1+
Hardware: All All
: medium normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:7.3.0 target:7.2.3
Keywords: filter:xlsx, implementationError
Depends on:
Blocks: XLSX-Autofilter AutoFilter-Color
  Show dependency treegraph
 
Reported: 2021-05-31 10:32 UTC by NISZ LibreOffice Team
Modified: 2021-10-04 12:10 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Calc (10.70 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-05-31 10:32 UTC, NISZ LibreOffice Team
Details
The original file saved by Calc (5.99 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2021-05-31 10:34 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document in Calc with conditional formatting settings (58.37 KB, image/png)
2021-05-31 10:34 UTC, NISZ LibreOffice Team
Details
Screenshot of the exported document in Calc with conditional formatting settings (55.66 KB, image/png)
2021-05-31 10:35 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-05-31 10:32:21 UTC
Created attachment 172482 [details]
Example file from Calc

Attached example file has conditional formatting set on cells with background color, and autofilter by color set on this color.
When saved to XLSX the conditional formatting color is overwritten with the autofiltered background color.


Steps to reproduce:
    1. Open attached file
    2. Save as XLSX, reload

Actual results:
The B1:B3 cells background color changes from pink to green, text color changes from red to black since it has changed in the Conditional Formatting dialog.

Expected results:
Conditional formatting style retained correctly.

LibreOffice details:
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 187136265d26c014e842550c2f1fc5997736e4fa
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2021-05-31 10:34:25 UTC
Created attachment 172483 [details]
The original file saved by Calc
Comment 2 NISZ LibreOffice Team 2021-05-31 10:34:45 UTC
Created attachment 172484 [details]
Screenshot of the original document in Calc with conditional formatting settings
Comment 3 NISZ LibreOffice Team 2021-05-31 10:35:02 UTC
Created attachment 172485 [details]
Screenshot of the exported document in Calc with conditional formatting settings
Comment 4 Michael Weghorn 2021-06-11 07:17:55 UTC
Reproduced with

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: 794eda02133699830913b37e094a07edeaeff22d
CPU threads: 12; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded
Comment 5 Xisco Faulí 2021-09-27 11:44:43 UTC
Still reproducible in

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: b63c5ade3554a42def4bce94f9fd67ea66528214
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 6 Commit Notification 2021-10-01 15:39:25 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b7a425d48cb282e20059e78ad5216da833dec803

tdf#142578: xlsx export: use continuous numbering for dfx nodes

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Samuel Mehrbrodt (allotropia) 2021-10-04 07:29:54 UTC
Fix works, thx!
Comment 8 Commit Notification 2021-10-04 12:10:07 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/c1e156e16d3f2a0c1393332b3ad3a20a267ab936

tdf#142578: xlsx export: use continuous numbering for dfx nodes

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.