Bug 142579 - FILEOPEN XLSX Conditional format background colors not considered by color filter
Summary: FILEOPEN XLSX Conditional format background colors not considered by color fi...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.0.0 alpha1+
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (allotropia)
URL:
Whiteboard: target:7.3.0 target:7.2.3
Keywords: implementationError
: 144010 144662 145105 (view as bug list)
Depends on:
Blocks: AutoFilter AutoFilter-Color
  Show dependency treegraph
 
Reported: 2021-05-31 10:36 UTC by NISZ LibreOffice Team
Modified: 2021-10-21 07:37 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Excel (10.89 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2021-05-31 10:39 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document in Excel (48.80 KB, image/png)
2021-05-31 10:41 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document Calc (2.70 MB, image/jpeg)
2021-05-31 10:41 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-05-31 10:36:47 UTC
Attached example file from Excel demonstrates a difference in behaviors: when cells are formatted by background color and conditional format both, Excel offers the conditional format colors for filtering by color while Calc does not.


Steps to reproduce:
    1. Open attached file
    2. Dropdown the B1 autofilter, select Background Color

Actual results:
Background color option offers green and yellow colors.

Expected results:
Background color should offer only the blue-white-pink colors defined by the conditional formatting and hide the actual cell background colors.
Also this should happen with new Calc files in the editor.

LibreOffice details:
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 187136265d26c014e842550c2f1fc5997736e4fa
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2021-05-31 10:39:21 UTC
Created attachment 172486 [details]
Example file from Excel
Comment 2 NISZ LibreOffice Team 2021-05-31 10:41:04 UTC
Created attachment 172487 [details]
Screenshot of the original document in Excel
Comment 3 NISZ LibreOffice Team 2021-05-31 10:41:51 UTC
Created attachment 172488 [details]
Screenshot of the original document Calc
Comment 4 Xisco Faulí 2021-05-31 14:15:19 UTC
Reproduced in

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: f49e5902a3737c02fabf5bec23243ccb126426c4
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 5 Commit Notification 2021-09-06 07:39:52 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/817ef891cf2bef8fdc82852f73acb422afb89bd2

tdf#142579 Consider color scale background colors in color filter

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Samuel Mehrbrodt (allotropia) 2021-09-06 08:49:20 UTC
*** Bug 144010 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2021-09-06 09:07:22 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/88e81b3c5f7167d7dfc93617c3f9d9d6633ba0ad

tdf#142579 Consider cond. format background colors in color filter

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2021-09-21 13:33:19 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4ba0460e3cf3ce33794090968fd4c906422bbd25

tdf#142579, tdf#143103: sc: Add UItest

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 NISZ LibreOffice Team 2021-09-22 13:23:01 UTC
*** Bug 144662 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2021-09-22 21:22:02 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2dd6c7e5d59126e28bf478439c25f9f4cbc3422c

tdf#142579: sc: Add UItest for cond. format background colors

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2021-09-24 12:20:54 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/63b004d4cab295c708686989869c9033ec91e449

tdf#142579 Consider color scale background colors in color filter

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2021-09-24 12:22:30 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/2391d8073624004e0cd657ab07ff947f6a9ef0c7

tdf#142579 Consider cond. format background colors in color filter

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Xisco Faulí 2021-09-24 16:45:59 UTC
Verified in

Version: 7.2.3.0.0+ / LibreOffice Community
Build ID: 2391d8073624004e0cd657ab07ff947f6a9ef0c7
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Samuel, thanks for fixing this issue!!
Comment 14 Buovjaga 2021-10-21 07:37:47 UTC
*** Bug 145105 has been marked as a duplicate of this bug. ***