Bug 142589 - UI Custom slide show dialogs Select button needs a change in the dialog to work
Summary: UI Custom slide show dialogs Select button needs a change in the dialog to work
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Tibor Nagy (NISZ)
URL: https://help.libreoffice.org/7.2/en-U...
Whiteboard: target:7.3.0 target:7.2.0.0.beta2
Keywords:
: 142595 (view as bug list)
Depends on:
Blocks: Slide-Show
  Show dependency treegraph
 
Reported: 2021-05-31 17:29 UTC by NISZ LibreOffice Team
Modified: 2021-07-16 09:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Impress with 2 custom slideshows (13.57 KB, application/vnd.oasis.opendocument.presentation)
2021-05-31 17:29 UTC, NISZ LibreOffice Team
Details
Example file from Impress with 1 custom slideshow. Try setting this to be used. (13.57 KB, application/vnd.oasis.opendocument.presentation)
2021-05-31 17:29 UTC, NISZ LibreOffice Team
Details
The checkbox does not remain checked (39.64 KB, image/png)
2021-05-31 17:30 UTC, NISZ LibreOffice Team
Details
The checkbox remains checked after selecting the first slideshow (35.24 KB, image/png)
2021-05-31 17:30 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-05-31 17:29:35 UTC
Created attachment 172504 [details]
Example file from Impress with 2 custom slideshows

Attached file contains a few slides and two custom slideshows.
Opening the Custom Slide Show dialog, checking the Use custom slide show box and pressing Start or OK does not set the default selected custom slideshow as active, only if something is changed in the dialog.

Steps to reproduce:
    1. Open attached file
    2. Open Slide Show – Custom Slide Show
    3. Check Use custom slide show and press Start (or OK and reopen the dialog)
    4. Or, select the first slideshow, then check Use custom slide show and press Start

Actual results:
In case 3 all four slides are shown, in case 4 the first and third slides are only shown.
If you press OK the Use custom slide show box does not remain checked upon reopening the dialog.

Expected results:
In case 3 the first and third slides should be shown as well. If you press OK the Use custom slide show box should remain checked upon reopening the dialog.
This is more annoying if you only have one custom slideshow in the file.

LibreOffice details:
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 187136265d26c014e842550c2f1fc5997736e4fa
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2021-05-31 17:29:54 UTC
Created attachment 172505 [details]
Example file from Impress with 1 custom slideshow. Try setting this to be used.
Comment 2 NISZ LibreOffice Team 2021-05-31 17:30:11 UTC
Created attachment 172506 [details]
The checkbox does not remain checked
Comment 3 NISZ LibreOffice Team 2021-05-31 17:30:37 UTC
Created attachment 172507 [details]
The checkbox remains checked after selecting the first slideshow
Comment 4 Timur 2021-06-01 11:00:14 UTC
Multiple issues here, Inherited from OO:

A. In case 3 problem seems to come from spaces in the custom SS name, as I reported bug 142595 for PPT, but looks ODP also. If renamed to no spaces or run after other custom SS, it runs OK. So I propose that one to be for this issue.

B. "If you press OK, Use custom SS checkbox should remain checked upon reopening the dialog."
I find it a special case 3 which is probably related to previous point. 
After 1st change, all other changes in the dialog are saved with OK. 

C. Once you check "Use custom SS" and Start, even if you didn't check OK, Slide Show – Slide Show Settings sets Custom SS. So F5 or Shift+F5 run that custom SS, not normal show from 1.
Not sure if it should or not, rather not. Because if you run custom SS once you may not want to do it always. You cannot run normal show from 1, until file is reopened. 
Help says that OK (called Close there) closes the dialog and saves all changes.
Seems that Start behaves with saving, which shouldn't. 

So bug could be about C, or D - adding UX:

D. Whole "Use custom SS checkbox" seems strange and unneeded. If you open Custom SS dialog, you obviously want to run custom SS, no checkbox needed. MSO also doesn't have it. 
So we could remove that checkbox and have 2 buttons, one Start (maybe renamed to Show) which would remember last ran show and other OK (Close and save changes to custom SS).

E. Obviously not this bug, but I think that Custom SS icon could have a drop-down with custom SS, as in MSO.
Comment 5 NISZ LibreOffice Team 2021-06-01 11:45:39 UTC
(In reply to Timur from comment #4)
> Multiple issues here, Inherited from OO:
> 
> A. In case 3 problem seems to come from spaces in the custom SS name, as I
> reported bug 142595 for PPT, but looks ODP also. If renamed to no spaces or
> run after other custom SS, it runs OK. So I propose that one to be for this
> issue.
> 

No, spaces in the custom slide show name don't have anything to do with this. In bug 142590 the attachment 172508 [details] has two custom slideshows without spaces in their names, yet if you don't change the selection in the dialog this problem persists.

"If renamed to no spaces or run after other custom SS, it runs OK

Yes because any of that is a change in this dialog.

> C. Once you check "Use custom SS" and Start, even if you didn't check OK,
> Slide Show – Slide Show Settings sets Custom SS. So F5 or Shift+F5 run that
> custom SS, not normal show from 1.
> Not sure if it should or not, rather not. Because if you run custom SS once
> you may not want to do it always. You cannot run normal show from 1, until
> file is reopened. 

But you can reset the range in the Slide Show Settings dialog. The Use custom slide show button sets the default setting there, that's one of the hings it does. Also it seems like if you don't check it, the Start button won't actually start the selected custom slideshow, so it's kinda necessary right now.


> Help says that OK (called Close there) closes the dialog and saves all
> changes.
> Seems that Start behaves with saving, which shouldn't. 
> 
> So bug could be about C, or D - adding UX:
> 
> D. Whole "Use custom SS checkbox" seems strange and unneeded. If you open
> Custom SS dialog, you obviously want to run custom SS, no checkbox needed.
> MSO also doesn't have it. 
> So we could remove that checkbox and have 2 buttons, one Start (maybe
> renamed to Show) which would remember last ran show and other OK (Close and
> save changes to custom SS).
> 

You can set the default custom slide show in the Slide Show Settings dialog, and the Start/OK button also sets this if the Use box is checked (and made change in the selection box :) ). So you don't have to reload the document.

So this dialog is kinda tangled right now:
- "Start" shows the slide range that is set in the Slide Show Settings dialog (All/From Slide N/Custom slideshow + dropdown), not what you have just selected.
- Checking "Use custom ss" changes this range setting to the selected custom slideshow
- Unchecking "Use custom ss" sets this range setting to "From Slide 1"

IMHO this dialog should not modify the slideshow range, just like it can not in PP. 
But I can understand that starting the selected custom slideshow could not be implemented without also changing the range, so someone short on time took the shorter route.


> E. Obviously not this bug, but I think that Custom SS icon could have a
> drop-down with custom SS, as in MSO.

I like this idea :)

Maybe also place it to the Standard toolbar next to "Start from first slide" and "Start from current slide" buttons.
Comment 6 Timur 2021-06-02 07:19:37 UTC
I propose bug 142595 be about A or B, this one C or D with UX, bug 142613 for E.
Comment 7 Heiko Tietze 2021-06-11 08:58:49 UTC
This "( ) Use custom slide show" checkbox is pointless. If I'm in the dislog about custom slide shows why would I want to run the full show? My take: drop this option, disable Start unless an item is selected, and fix the bugs.

Or we split the creation of custom slideshows (this dialog) from running, as suggested in bug 142613 (not my prefered solution).
Comment 8 Commit Notification 2021-06-29 17:17:57 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a46a847d4298806d4e91e4665c3c1907c09a17c7

tdf#142589 Impress UI: fix Start button of Custom Slide Shows

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2021-06-29 20:50:48 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/f7567758d2a1024580b18bef4156e59e63ac9f6d

tdf#142589 Impress UI: fix Start button of Custom Slide Shows

It will be available in 7.2.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Timur 2021-06-30 15:07:29 UTC Comment hidden (obsolete)
Comment 11 NISZ LibreOffice Team 2021-07-05 07:50:30 UTC
Verified in: 

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 3964e0854507b2696ae0fbe48a4fb005c779947e
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: default; VCL: win
Locale: en-DK (hu_HU); UI: en-GB
Calc: threaded
Comment 12 Timur 2021-07-15 08:44:10 UTC
Looking good. 

"( ) Use custom slide show" checkbox wass removed and Start starts the show once. 
(F5 later starts normal show). 
As explained in the commit:
Now Start button of the dialog starts the selected custom slide
show only once, i.e. it doesn't modify the global slide show
settings for all the next slide shows (that is already handled
by Slide Show->Slide Show Settings->Range->"Custom slide show:"
and Slide Show->Slide Show Settings->Range->"All slides").

OK saves changes. 

"disable Start unless an item is selected" some item is always selected if custom show present, and Start disabled if no custom show, so this is good.

Thanks.
Comment 13 Timur 2021-07-16 09:18:15 UTC
*** Bug 142595 has been marked as a duplicate of this bug. ***