Bug 142644 - UI: Languages without hyphenation shouldn't show a warning message
Summary: UI: Languages without hyphenation shouldn't show a warning message
Status: RESOLVED DUPLICATE of bug 131233
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2021-06-04 09:09 UTC by Thomas Lendo
Modified: 2021-06-07 07:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Yellow infobar mentioning a hyphenation package (5.34 KB, image/png)
2021-06-04 09:10 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2021-06-04 09:09:02 UTC
If hyphenation is activated in a document with for example Chinese text, then a yellow infobar / warning message appears at every time you open the document.

Issue 1:
This infobar is useless for languages without any hyphenation concept

Issue 2:
The user don't know what to do with this information. A hyperlink to a download page would be best for usability.




This was also mentioned at https://ask.libreoffice.org/en/question/238764/error-message-reads-install-the-hyphenation-package-for-locale-zh/

Tested with

Version: 6.4.7.2 (x64)
Build-ID: 639b8ac485750d5696d7590a72ef1b496725cfb5
CPU-Threads: 12; BS: Windows 10.0 Build 19041; UI-Render: GL; VCL: win

Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: eda109d5d91e82adb675ebf6db952bf6d82b3391
CPU threads: 12; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Comment 1 Thomas Lendo 2021-06-04 09:10:15 UTC
Created attachment 172607 [details]
Yellow infobar mentioning a hyphenation package
Comment 2 Thomas Lendo 2021-06-04 09:16:15 UTC
Hm, there was a Bug 132396 >"Missing hyphenation info" pop-up banner displayed for Chinese which has no concept of hyphenation<  but it was closed as a dupe of a Google Docs issue?!

Issue with missing further information or hyperlink is already mentioned in bug 131233.
Comment 3 Ming Hua 2021-06-04 09:22:37 UTC
(In reply to Thomas Lendo from comment #2)
> Hm, there was a Bug 132396 >"Missing hyphenation info" pop-up banner
> displayed for Chinese which has no concept of hyphenation<  but it was
> closed as a dupe of a Google Docs issue?!
Yes, I believe your screenshot in comment #1 is the same problem as bug 132396: the language of the text is specified as "zh" instead of the more specific "zh-cn" or "zh-tw".

I don't believe documents created by LibreOffice itself will have this language specification.
Comment 4 Heiko Tietze 2021-06-07 07:25:25 UTC
#1 is apparently bug 132396 and #2 bug 131233.

*** This bug has been marked as a duplicate of bug 131233 ***