Bug 142649 - LibreOffice window size is too small after resizing with clicking the "Restore Down" button
Summary: LibreOffice window size is too small after resizing with clicking the "Restor...
Status: RESOLVED DUPLICATE of bug 97894
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.7.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-04 11:35 UTC by BinLi
Modified: 2021-07-26 20:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
On ubuntu 20.04.2, the screenshot of this issue. (54.55 KB, image/jpeg)
2021-06-04 11:36 UTC, BinLi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BinLi 2021-06-04 11:35:19 UTC
Description:
Click the "Restore Down" button, the window resize very very small.

Steps to Reproduce:
1. Launch any one of the LibreOffice group app, such as writer, then close it directly.
2. Launch writer again. 
3. Click the "Restore Down" button of the app's menu tray bar

Actual Results:
The window size by default is not correct.

Expected Results:
Display normal after 'Restore down'


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Debugged more about it, found the initial position in ~/.config/libreoffice/4/user/registrymodifications.xcu which made it small. If I removed the ooSetupFactoryWindowAttributes line, and restart the libreoffice, it could drop-down into the middle of screen, it expects behavior. If I don't 'Restore down' at the first time and close it, this issue will be reproduced.

<prop oor:name="ooSetupFactoryWindowAttributes" oor:op="fuse"><value>0,64,4,4;5;0,64,1712,899;</value></prop>

The value of that prop can be interpreted as follows:

x-pos,y-pos,width,height;window-state;maximized-x-pos,maximized-y-pos,maximized-width,maximized-height;
Comment 1 BinLi 2021-06-04 11:36:25 UTC
Created attachment 172620 [details]
On ubuntu 20.04.2, the screenshot of this issue.
Comment 2 BinLi 2021-06-04 11:37:53 UTC
<item oor:path="/org.openoffice.Setup/Office/Factories/org.openoffice.Setup:Factory['com.sun.star.text.TextDocument']"><prop oor:name="ooSetupFactoryWindowAttributes" oor:op="fuse"><value>72,64,2,2;5;72,64,1848,1016;</value></prop></item>

If I set 72,64,2,2 to 72,64,2000,2000, then it looks good, so I want know how the libreoffice set this value.
Comment 3 Dmitriy Siushkin 2021-07-23 07:41:06 UTC
no repro in

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: c5ca46e75e28ba4245d8544ca53c71fea87d1bbd
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: en-US (ru_RU); UI: en-US
Calc: CL
Comment 4 BogdanB 2021-07-26 20:45:44 UTC

*** This bug has been marked as a duplicate of bug 97894 ***