Bug 142761 - optimization of the ergonomics and appearance of the automatic filter menu
Summary: optimization of the ergonomics and appearance of the automatic filter menu
Status: RESOLVED DUPLICATE of bug 142522
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.0.0 alpha1+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2021-06-10 11:46 UTC by kabilo
Modified: 2021-06-11 08:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
proposal of optimization of the automatic filter (183.46 KB, image/jpeg)
2021-06-10 11:47 UTC, kabilo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kabilo 2021-06-10 11:46:02 UTC
Description:
I've attached a proposal to optimize the auto-filtering menu after adding a color filter (inspiration is MSO). I think it is unnecessary to increase the number of rows (options) in the menu for the filter by color (+ separator). In addition, you must check 3 options to determine which filter is active.
Proposal:
- option to filter items without background or with automatic text color is added to filter by color
- the active filter identifier is displayed before the corresponding menu item (checkbox)
- possibility to select multiple colour combinations by checkbox (or only as a variant of the selected colour identifier)
- added design of the original appearance of the automatic filter to version 7.0 (for me it is the most visually optimal variant)
Thanks

Actual Results:
 

Expected Results:
fewer menu items, better ergonomics, better appearance (filtered items are more prominent), 


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 kabilo 2021-06-10 11:47:01 UTC
Created attachment 172765 [details]
proposal of optimization of the automatic filter
Comment 2 Heiko Tietze 2021-06-11 08:04:12 UTC
You made the same proposal at bug 142522, maybe a bit less elaborated. But we should keep topics concise and I recommend to make this a duplicate.

Basically I like the idea, both merging font and background into one dropdown and having checkboxes. The automatic/none setting seems to conflict with the actual values but the point is that users may use it together with formatted cells. So this addition is also useful.

My take: add this input to the other ticket. And if necessary, adjust the summary.

*** This bug has been marked as a duplicate of bug 142522 ***