Bug 142769 - calc - Hidden cells are visible when reopening edited file
Summary: calc - Hidden cells are visible when reopening edited file
Status: RESOLVED DUPLICATE of bug 128895
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-10 16:02 UTC by mrkalvin
Modified: 2021-06-10 16:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mrkalvin 2021-06-10 16:02:07 UTC
Description:
When I edit a file with hidden rows or columns, I save the file. When reopening the file, new lines or columns are created in place of those that are hidden.

Steps to Reproduce:
1) I create a calc ods spreadsheet file

2) hidden columns from D to last column

3) save the file and close

4) I reopen the file and type something in some cell

5) save the file again and close

6) reopen the file

7) the cells that were hidden in step 2 are now visible \ Create new columns visible to the left

Actual Results:
the cells that were hidden in step 2 are now visible \ Create new columns visible to the left

Expected Results:
the expected behavior is to continue only with columns A through D without any other visible columns


Reproducible: Always


User Profile Reset: No



Additional Info:
https://ask.libreoffice.org/en/question/313451/calc-hidden-cells-are-visible-when-reopening-edited-file-bug/
Comment 1 [REDACTED] 2021-06-10 16:08:31 UTC
Repro

Version: 7.1.4.2 / LibreOffice Community
Build ID: a529a4fab45b75fefc5b6226684193eb000654f6
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 2 m.a.riosv 2021-06-10 16:14:38 UTC

*** This bug has been marked as a duplicate of bug 128895 ***