Bug 142773 - Adding 4 new rows in complex table causes hang
Summary: Adding 4 new rows in complex table causes hang
Status: RESOLVED DUPLICATE of bug 121720
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0 alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-10 19:40 UTC by Telesto
Modified: 2021-07-22 08:26 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (36.85 KB, application/vnd.oasis.opendocument.text)
2021-06-10 19:41 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-06-10 19:40:37 UTC
Description:
Adding 4 new rows in complex table causes hang

Steps to Reproduce:
1. Open the attached file
2. Go to row 104
3. Press add row below 4 times

Actual Results:
Hang

Expected Results:
No hang


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 3b57ebb445df8a2bc3d916ea79f8af45e20e4e62
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2021-06-10 19:41:00 UTC
Created attachment 172773 [details]
Example file
Comment 2 Telesto 2021-06-10 19:43:28 UTC
Table bored from bug 124795 (copy/paste to new document ODT)
Comment 3 Telesto 2021-06-10 19:48:15 UTC
OK in
Versie: 5.2.4.2 
Build ID: 3d5603e1122f0f102b62521720ab13a38a4e0eb0
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: GL; 
Locale: nl-NL (nl_NL); Calc: CL

guessing:  8a800eea613c0f5ad3302136766791dc58880fb3 being the bad commit
tdf#104425 sw: split rows w/large min height (fix layout loop)
Comment 4 holola hero 2021-06-15 09:12:14 UTC Comment hidden (spam)
Comment 5 Timur 2021-06-18 14:04:42 UTC
1st problem is hanging on scrolling down and up in this ODT, similar as with DOCX attachment 157151 [details] from bug 124795. Both as LO saved. 
2nd problem is as reported, adding rows. 
Both hang for a while with rising CPU, but no crash.
Comment 6 Telesto 2021-06-18 14:16:49 UTC
Moving it to bug 121720. Pretty convinced it's the same thing (and can be checked after fix for bug 121720)

*** This bug has been marked as a duplicate of bug 121720 ***
Comment 7 Telesto 2021-07-22 08:26:17 UTC
Still present with
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 3d18cae102e16b85fb8787f5ec3b086bfa2bd7b8
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL