Bug 142791 - Find & Replace:Two keys required (Alt + <letter>) to activate command shortcut in Linux (GTK); compared to only one key in Windows
Summary: Find & Replace:Two keys required (Alt + <letter>) to activate command shortcu...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-11 10:35 UTC by R. Green
Modified: 2021-06-28 11:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description R. Green 2021-06-11 10:35:50 UTC
Version: 7.1.3.2 / LibreOffice Community
Build ID: 47f78053abe362b9384784d31a6e56f8511eb1c1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.UTF-8); UI: en-GB
Calc: threaded

This concerns the AppImage version on Linux Mint. There are issues with using menu and dialog shortcuts in LINUX generally. I will focus on the Find & replace dialog as an example.

Open the attached Writer file in a Linux distro. Open the Find & Replace dialog.

EXPECTED RESULT: The shortcut keys should be automatically underlined in the dialog. 

ACTUAL RESULT: No letters are underlined; and, in fact, there is no shortcut letter underlining visible in the program AT ALL. You need to press Alt in order to bring up the shortcut letter underlining.

I am a new Linux user, but in Windows the shortcuts are automatically underlined. And in Windows dialogs you only have to press the letter to activate the shortcut – NOT the Alt button as well.
Comment 1 R. Green 2021-06-11 10:39:45 UTC
Note: Ignore the reference to an attached Writer file: just open any document.
Comment 2 V Stuart Foote 2021-06-13 14:53:53 UTC
Actually beleive this is expected behavior with GNOME GTK3 based desktop environment.

Implemented at 5.1 for bug 92630 [1]

=> NAB

=-ref-=
[1] https://gerrit.libreoffice.org/c/core/+/16883/
Comment 3 R. Green 2021-06-13 16:39:21 UTC
The Alt + <shortcut> behaviour is fine when accessing MENU commands. But in a dialog box, such as Find & replace, having to press TWO keys, i.e. Alt + <shortcut letter>, is a minus factor.
Comment 4 Justin L 2021-06-28 11:21:18 UTC
(In reply to V Stuart Foote from comment #2)
> Actually beleive this is expected behavior with GNOME GTK3 based desktop
> environment.
> => NAB

I see the same thing in GIMP and Inkscape on Ubuntu 20.04/Cinnamon desktop. Since it matches the behaviour of the chosen OS interface, NOTABUG.