Download it now!
Bug 142860 - Crash: press Page Columns Button on Tab UI
Summary: Crash: press Page Columns Button on Tab UI
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0 alpha1+
Hardware: All All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:7.3.0 target:7.2.0.0.beta2
Keywords: bibisectRequest, haveBacktrace, regression
: 143270 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-06-15 03:16 UTC by sawakaze
Modified: 2021-07-09 10:05 UTC (History)
6 users (show)

See Also:
Crash report or crash signature: https://crashreport.libreoffice.org/stats/crash_details/7ea320de-284e-4363-b778-be7d23b1953f


Attachments
gdb bt (8.63 KB, text/plain)
2021-06-15 18:41 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sawakaze 2021-06-15 03:16:34 UTC
Description:
After Following Steps, Libreoffice was crashed.

Steps to Reproduce:
1. Open writer 
2. Press view -> User Interface
3. select Tabbed and apply to writer 
--> Change UI to tabbed
4. select Layout tab and press Page Columns Button 
--> application crash

Actual Results:
application crash

Expected Results:
not crash
show Page Columns List


Reproducible: Always


User Profile Reset: Yes



Additional Info:
I confirmed this version

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: bb54d6d8241a06a6772052b77b67d6a4f686426c
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (C); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-06-11_20:14:38
Calc: threaded

----

I could "not" confirm this version

Version: 7.1.4.2 / LibreOffice Community
Build ID: a529a4fab45b75fefc5b6226684193eb000654f6
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (C); UI: en-US
Calc: threaded
Comment 1 Telesto 2021-06-15 07:31:28 UTC
Repro
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 239b4bb27fd8db26e8416045b3015688a8b1b0ae
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 2 Telesto 2021-06-15 07:32:32 UTC
No issue with
Version: 6.3.0.0.alpha0+
Build ID: 4985bdc40738dedd9ae2571e660189c0ffa65541
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 3 Xisco Faulí 2021-06-15 09:11:01 UTC
The bisect repository points to

author	Caolán McNamara <caolanm@redhat.com>	2021-06-01 17:33:57 +0100
committer	Jan-Marek Glogowski <glogow@fbihome.de>	2021-06-02 08:24:35 +0200
commit	a3a203b7c697a38d4f79877d6b5c1423fa52f2d8 (patch)
tree	24f5a6fc6b18483304ebbce94337f1c7876d6c80
parent	566370dc3754ed3f858f1617e776ec0bc3399499 (diff)
enabling gtk vclplugs is supposed to enforce requiring system cairo

But I'm not sure this is the problematic commit. The issue is also reproducible with GEN

@Caolán, Any idea what the problem might be here ?
Comment 4 Julien Nabet 2021-06-15 18:41:34 UTC
Created attachment 172924 [details]
gdb bt

On pc Debian x86-64 with master sources updated today + gtk3 rendering, I could reproduce this.

Interestingly console logs show:
warn:vcl.gtk:26076:26076:vcl/unx/gtk3/gtkinst.cxx:21301: GtkInstanceBuilder: error when calling gtk_builder_add_from_file: L’ouverture du fichier « /home/julien/lo/libreoffice/instdir/program/../share/config/soffice.cfg/modules/swriter/ui/pagecolumncontrol.ui » a échoué : Aucun fichier ou dossier de ce type
soffice.bin: /home/julien/lo/libreoffice/vcl/unx/gtk3/gtkinst.cxx :21304 : void (anonymous namespace)::load_ui_file(GtkBuilder *, const rtl::OUString &):  l'assertion « rc && "could not load UI file" » a échoué
Comment 5 Julien Nabet 2021-06-15 18:44:05 UTC
With https://gerrit.libreoffice.org/c/core/+/117268, I don't reproduce the crash.
Comment 6 Commit Notification 2021-06-15 19:50:13 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b89ebf135818ccaa45bbfb164099a6e199bd7d11

tdf#142860: fix crash: press Page Columns Button on Tab UI

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Julien Nabet 2021-06-15 19:52:00 UTC
Backport for 7.2 waiting for review here: https://gerrit.libreoffice.org/c/core/+/117228
Comment 8 Commit Notification 2021-06-16 07:30:05 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/9656cc894673af9db77a29376a94d3029370d127

tdf#142860: fix crash: press Page Columns Button on Tab UI

It will be available in 7.2.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Caolán McNamara 2021-06-16 08:42:46 UTC
Thanks Julien. For the record the newly restored line appears to originally have gone missing with...

commit 9f06c54ca1819b6d4df48f33772cfa5ceb90dccd
Author: Szymon Kłos <szymon.klos@collabora.com>
Date:   Tue Apr 6 07:08:30 2021 +0200

    notebookbar: minify for online
Comment 10 BogdanB 2021-06-19 12:04:15 UTC
No crash in
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 51754ca5349d7bf655d57ded37381188d0bc4bcf
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 11 Julien Nabet 2021-07-09 10:05:27 UTC
*** Bug 143270 has been marked as a duplicate of this bug. ***