Bug 142873 - Calc: Print preview zoom-out zoom-in buttons don't work in 'Tabbed' UI, nor in 'Grouped Bar Compact' UI mode
Summary: Calc: Print preview zoom-out zoom-in buttons don't work in 'Tabbed' UI, nor i...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.3.2 release
Hardware: All All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:7.3.0 target:7.2.0.0.beta2 tar...
Keywords: bibisected, bisected, regression
: 143253 (view as bug list)
Depends on:
Blocks: Notebookbar
  Show dependency treegraph
 
Reported: 2021-06-15 10:02 UTC by Timur
Modified: 2021-07-08 12:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2021-06-15 10:02:45 UTC
Calc Print preview zoom doesn't work in Tabbed UI.
No repro 7.0 master, repro 7.1 master and 7.2+, regression.
Comment 1 Timur 2021-06-15 10:16:49 UTC
Linux 7.1:
commit 8a2dd7cb300c0ffdafd7d5f3a4b2ce9778783ed1
Date:   Fri Nov 13 19:09:27 2020 +0100

author	Jim Raykowski <raykowj@gmail.com>	2020-10-11
committer	Jim Raykowski <raykowj@gmail.com>	2020-11-13 
commit	95b27dd2e5b5bdcb39962f72882dcdf406bcb393 (patch)
tdf#45705 rework zoom in and zoom out UI commands in Calc

CC Jim, please see also this one on zoom.
Comment 2 Xisco Faulí 2021-06-15 11:00:34 UTC
Reproduced in

Version: 7.2.0.0.beta1+ / LibreOffice Community
Build ID: d376297c643785564e7bda1a74b573c35ade6cb8
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 3 V Stuart Foote 2021-06-15 13:27:19 UTC
While in 'Tabbed' NB Print Preview VCL mode--e.g. the 'File' tab -> Print block's 'Print Preview'-- the preview canvas does zoom-out / zoom-in via keyboard *if* the corresponding UNO commands (.uno:ZoomMinus / .uno:ZoomPlus)  are assigned to a keyboard shortcut.

So, it is just the command linkages to the button actions for the Print Preview mode for just the Tabbed NB UI. Weird bcz the buttons do receive the correct shortcut label when they've been assigned.

The 'Grouped Bar Compact' NB also will not zoom its Print Preview VCL via its GUI buttons. But like the Tabbed NB mode zooms when shortcuts are applied and used.

The other MUFFIN NB modes, including the 'Tabbed Compact' and the experimentals, seem to make the right connections, the zoom-out and zoom-in buttons work, with or without a shortcut assigned. 

Note: toggling to Print Preview VCL mode may require exposing the Std Menubar and use of the 'File' menu to access the mode for some of the NB modes.
Comment 4 Julien Nabet 2021-06-15 20:09:54 UTC
I gave a try with https://gerrit.libreoffice.org/c/core/+/117279

Jim: as you may have seen, I put you as reviewer since you may have some opinion.

If Jenkins is ok and no one complains, I'll push this some people may give it a try.
Comment 5 Commit Notification 2021-06-18 17:38:46 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c21398066b6bf630070ed291456f2663e06d94b9

tdf#142873: Fix print preview zoom-out zoom-in buttons

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Julien Nabet 2021-06-18 17:40:56 UTC
Cherry-pick for 7.2 waiting for review here:
https://gerrit.libreoffice.org/c/core/+/117424
Comment 7 Commit Notification 2021-06-20 07:07:09 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/d23b3992a4df64d2dfd7d2c593b1589dadd68d40

tdf#142873: Fix print preview zoom-out zoom-in buttons

It will be available in 7.2.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2021-06-21 03:32:09 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/c82178535780df2b54c80b084e9d9e6eb453fac2

tdf#142873: Fix print preview zoom-out zoom-in buttons

It will be available in 7.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 V Stuart Foote 2021-07-08 12:43:58 UTC
*** Bug 143253 has been marked as a duplicate of this bug. ***