Bug 142882 - LibreOffice tiny GUI elements running on hidpi Linux KDE Plasma 5.22 Wayland
Summary: LibreOffice tiny GUI elements running on hidpi Linux KDE Plasma 5.22 Wayland
Status: RESOLVED DUPLICATE of bug 137924
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 138520 (view as bug list)
Depends on:
Blocks: HiDPI Wayland KDE
  Show dependency treegraph
 
Reported: 2021-06-15 21:44 UTC by mir.einer
Modified: 2021-07-25 05:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot (xcb on the left, wayland on the right) (126.08 KB, image/png)
2021-06-23 10:06 UTC, Michael Weghorn
Details
LibreOffice Writer 7.1.4-1 in Wayland mode running on Fedora 35 KDE Plasma rawhide live ISO with KDE Plasma 5.22.1 desktop (124.36 KB, image/png)
2021-06-23 18:49 UTC, mir.einer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mir.einer 2021-06-15 21:44:38 UTC
Description:
LibreOffice 7.1.4-1 got tiny dialog boxes, symbols and toolbars running on following system:

OS: Linux with KDE Plasm 5.22 desktop running on "Wayland"!
Graphics: Intel UHD 630
Monitor: 27", 2556x1440 resolution (KDE Plasma scaling 150%)

Steps to Reproduce:
1. Start LibreOffice Writer on Linux KDE Plasma 5.22 with Wayland
2. 
3.

Actual Results:
Toolbars, symbols, buttons and dialog-boxes are tiny - too small

Expected Results:
Toolbars, symbols, buttons and dialog-boxes are scaled correctly in normal size.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
LibreOffice scales fine running on same hardware with Gnome 40 desktop (GTK) on Wayland with same 150% scaling. So this bug is only related to LibreOffice Qt on Wayland.
Comment 1 Michael Weghorn 2021-06-23 10:06:16 UTC
Created attachment 173103 [details]
Screenshot (xcb on the left, wayland on the right)

Reproduced in a Plasma Wayland session on Debian testing (libqt5core5a:amd64 5.15.2+dfsg-7, plasma-desktop 4:5.20.5-4) with

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 949658028e722e5d2657b503eb20e16e41dbd8cf
CPU threads: 12; OS: Linux 5.10; UI render: default; VCL: kf5 (cairo+wayland)
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

and QT_SCALE_FACTOR=2 env variable set.

It works OK when using the Qt xcb platform plugin instead:

    QT_QPA_PLATFORM=xcb QT_SCALE_FACTOR=2 lo --writer

Screenshot attached (xcb on the left, wayland on the right)
Comment 2 Michael Weghorn 2021-06-23 10:07:38 UTC
Not sure whether all of this is LO's own problem or there might be aspects in Qt/KF5, since e.g. the native Qt menu also behaves a bit "interestingly"...
Comment 3 Michael Weghorn 2021-06-23 10:17:24 UTC
*** Bug 138520 has been marked as a duplicate of this bug. ***
Comment 4 mir.einer 2021-06-23 18:45:52 UTC
For testing one can use Fedora 35 KDE Plasma rawhide live ISO:

Fedora-KDE-Live-x86_64-Rawhide-20210615.n.1.iso

https://fedoraproject.org/wiki/Test_Results:Fedora_35_Rawhide_20210615.n.1_Installation?rd=Test_Results:Current_Installation_Test

It comes with latest KDE Plasma 5.22.1 and runs in Wayland mode as default. Also latest LibreOffice fresh 7.1.4-1 is installed.
Comment 5 mir.einer 2021-06-23 18:49:08 UTC
Created attachment 173117 [details]
LibreOffice Writer 7.1.4-1 in Wayland mode running on Fedora 35 KDE Plasma rawhide live ISO with KDE Plasma 5.22.1 desktop
Comment 6 Doug 2021-07-25 05:17:36 UTC

*** This bug has been marked as a duplicate of bug 137924 ***