Bug 143173 - Writer - Alphabetical Index - Grouped entries abbreviation not localised (in fr_FR)
Summary: Writer - Alphabetical Index - Grouped entries abbreviation not localised (in ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.4.2 release
Hardware: All All
: medium minor
Assignee: Julien Nabet
URL:
Whiteboard: target:7.3.0 target:7.2.0.0.beta2
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-03 10:28 UTC by Gregoire C
Modified: 2021-07-07 18:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screnshot Edit Index panel + actual document (43.87 KB, image/png)
2021-07-03 10:30 UTC, Gregoire C
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gregoire C 2021-07-03 10:28:48 UTC
Description:
With the French version of Writer (v7.1.4.2), I still get an old (and unwanted) abbreviation to qualify grouped entries in the index. 

Currently, in the FR version, an index entry appearing on consecutive pages displays the first page number in the range followed with the "sv" abbrev.: 
ENTRY ... 1 sv 

Also, the same "sv" abbrev. is used to cover the cases rendered in English with "p" (2 consecutive pages, i.e. "1-2") and "pp" (more than 2 consecutive pages, i.e. "1-5"). 

I had discussed the matter with the localisation team several months ago, and they had agreed to use the more formal and widely used abbreviations "sq." (EN: p) and "sqq." (EN: pp). 

Since then, the localisation team did their part and updated the translations which show up in the UI (Edit Index panel). Unfortunately, Writer doesn't behave according to the wording in the panel. See screenshot. 

This is a rather minor issue. I can update manually the "sv" string in the final index, but it is painful and I don't think it is a good idea to show discrepancies between the messages in the UI and the behaviour of the software.

Could we implement the display of the abbreviations as per the specs for the French version? 
- 2 consecutive pages ==> "sq." 
- 3 or more consecutive pages ==> "sqq." 


Steps to Reproduce:
With a fr_FR version of Writer: 
1. Create a document with 3 pages 
2. Create the same index entry on each page 
3. Create an alphabetical index 

Actual Results:
ENTRY ... 1 sv 

Expected Results:
ENTRY ... 1 sqq. 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.4.2 (x64) / LibreOffice Community
Build ID: a529a4fab45b75fefc5b6226684193eb000654f6
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: fr-FR (fr_FR); UI: fr-FR
Calc: threaded
Comment 1 Gregoire C 2021-07-03 10:30:45 UTC
Created attachment 173328 [details]
Screnshot Edit Index panel + actual document
Comment 2 Julien Nabet 2021-07-03 21:51:24 UTC
On pc Debian x86-64 with master sources updated today + French locale, I could reproduce this.
Comment 3 Julien Nabet 2021-07-03 21:54:24 UTC
I gave a try with https://gerrit.libreoffice.org/c/core/+/118366

Sophie/Jean-Baptiste: thought you might be interested in this one since it concerns French localization.
Comment 4 Commit Notification 2021-07-04 08:05:47 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0151a178d4e26b4546f7b27d569f0d94420caa9d

tdf#143173: fix wrong French abbr for Alphabetical Index-Grouped entries

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Julien Nabet 2021-07-04 08:16:44 UTC
Patch waiting for review in 7.2 branch here:
https://gerrit.libreoffice.org/c/core/+/118307

I don't think it worths it to backport this on 7.1 branch but wouldn't be against it.
Comment 6 Gregoire C 2021-07-04 12:18:43 UTC
Thanks for the follow-up. 
The matter had been discussed a few months ago. The thread is available here: 
https://listarchives.libreoffice.org/fr/doc/msg01617.html
Comment 7 Commit Notification 2021-07-04 23:22:27 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/7c7f113723ec5e908957cd4ae43ef0f3ec643504

tdf#143173: fix wrong French abbr for Alphabetical Index-Grouped entries

It will be available in 7.2.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Gregoire C 2021-07-06 07:24:15 UTC
Gave it a try with: 
Version: 7.2.0.0.beta1+ (x64) / LibreOffice Community
Build ID: 7c7f113723ec5e908957cd4ae43ef0f3ec643504
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: fr-FR (fr_FR); UI: fr-FR
Calc: threaded

and it works as expected. 

Many thanks!
Comment 9 Julien Nabet 2021-07-07 18:49:02 UTC
Thank you for your feedback! Let's put this one to VERIFIED then.