Bug 143204 - Tabbed interface not working in Impress or Draw
Summary: Tabbed interface not working in Impress or Draw
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.3.0 target:7.2.0.0.beta2
Keywords: bibisected, bisected, regression
: 143243 (view as bug list)
Depends on:
Blocks: Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2021-07-05 14:50 UTC by Buovjaga
Modified: 2021-07-16 19:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2021-07-05 14:50:14 UTC
1. View - User interface, change to Tabbed

The tabbed interface is only visible in Writer and Calc.

Bibisected with linux-64-7.3 to https://git.libreoffice.org/core/commit/dd5bf12193471f064bf7f581dd1b21783390e735

editengine-columns: add sidebar property panel

Adding Cc: to Mike Kaganski

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 0afa7e64d547a8f2a48402660acf5c95a468a0ab
CPU threads: 2; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded Jumbo
Comment 1 Hossein 2021-07-05 15:10:42 UTC
Confirming that this bug exists in the latest LibreOffice master, but did NOT existed in 7.1.3.2.

Affected version: (Linux)
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: f5ff7a967b09a715c56630aff92cfb636e7c232b
CPU threads: 8; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Affected version: (Windows)
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: cf3a9960345b22429233d1b5f1a9a0a3a086f483
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 2 Commit Notification 2021-07-07 15:43:31 UTC
Hossein committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8ea9a8bc43ea054521a44dc8e3bc537110ca9e33

tdf#143204 svx: fix SID_ATTR_TEXTCOLUMNS_SPACING SID collision

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Buovjaga 2021-07-07 16:26:41 UTC
Thanks, it's working now :)

I ran into this in my live streaming and Hossein saw it and picked it up

Arch Linux 64-bit
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: f6b143a57d9bd8f5d7b29febcb4e01ee1eb2ff1d
CPU threads: 8; OS: Linux 5.12; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 7 July 2021
Comment 4 Aron Budea 2021-07-07 18:06:55 UTC
*** Bug 143243 has been marked as a duplicate of this bug. ***
Comment 5 Rafael Lima 2021-07-07 18:49:47 UTC
I've just built it again from source after Hossein's patch and it's working. Thanks
Comment 6 Commit Notification 2021-07-07 19:49:58 UTC
Hossein committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/7c1221f15ced762b6ffcfd4abf6ebc2327f0341f

tdf#143204 svx: fix SID_ATTR_TEXTCOLUMNS_SPACING SID collision

It will be available in 7.2.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Aron Budea 2021-07-16 19:30:00 UTC
I presume this can be set to FIXED, it's fine in LO 7.2.0.1.
Thanks for fixing, Hossein!