Bug 143215 - FILEOPEN DOCX Inserting a row to a Word table does not appear in Writers Manage Changes panel
Summary: FILEOPEN DOCX Inserting a row to a Word table does not appear in Writers Mana...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: medium normal
Assignee: László Németh
URL:
Whiteboard: target:7.3.0 target:7.2.0.2
Keywords: bibisected, bisected, filter:docx, regression
: 143260 (view as bug list)
Depends on:
Blocks: DOCX-Track-Changes
  Show dependency treegraph
 
Reported: 2021-07-06 14:32 UTC by NISZ LibreOffice Team
Modified: 2021-09-03 15:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The example file with the table created in MS Word (12.74 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-07-06 14:32 UTC, NISZ LibreOffice Team
Details
Screenshot of the document side by side in Writer and Word (87.80 KB, image/png)
2021-07-06 14:33 UTC, NISZ LibreOffice Team
Details
The example file right before commit c4cf857 (152.84 KB, image/png)
2021-07-09 10:28 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-07-06 14:32:51 UTC
Created attachment 173387 [details]
The example file with the table created in MS Word

Adding a new row to an existing Word table is displayed in MSO Word’s Reviewing Pane. In Writer, after opening this .docx file, the Manage Changes panel does not contains this information.

Steps to reproduce:
1.	Open attached .docx file in MS Word.
2.	In the Reviewing pane, we can see the changes (inserted a new row to the table).
3.	Open attached .docx file in LO Writer.
4.	Under the Manage Changes panel, this information disappears.

Actual results:
After opening the file in Writer, we can’t see the inserted row in the Manage changes panel.
Note: inserting an empty row to a table in Writer does not create a new CT entry either.

Expected results:
This information should be displayed in the Manage Changes panel like in MS Word.

LibreOffice details:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: bd2f2273d83dcca43eb6b465308707efd45e7adf
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded
Comment 1 NISZ LibreOffice Team 2021-07-06 14:33:10 UTC
Created attachment 173388 [details]
Screenshot of the document side by side in Writer and Word
Comment 2 NISZ LibreOffice Team 2021-07-09 10:28:43 UTC
Created attachment 173474 [details]
The example file right before commit c4cf857

Turns out this was good before this one:

URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=c4cf85766453982f1aa94a7f2cb22af19ed100be 

author	Michael Stahl <mstahl@redhat.com>	2015-05-05 23:15:20 +0200
committer	Michael Stahl <mstahl@redhat.com>	2015-05-06 00:10:17 +0200

sw: fix crash due to redlines on tables on ooo121112-2.docx
Comment 3 Commit Notification 2021-07-13 14:50:01 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a483a44ca00f43a64ae51d62b8fbb4129a413f6d

tdf#143215 DOCX import: fix tracked empty row insertion/deletion

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2021-07-15 10:55:09 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/c59b6cbfb8aebbfde2ad11fdf884726e2524aa5d

tdf#143215 DOCX import: fix tracked empty row insertion/deletion

It will be available in 7.2.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 NISZ LibreOffice Team 2021-07-23 07:52:18 UTC
*** Bug 143260 has been marked as a duplicate of this bug. ***
Comment 6 NISZ LibreOffice Team 2021-08-04 05:53:51 UTC
Verified in: 

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: ad1b12686da88bea57582df10fa85268ada209b8
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded
Comment 7 Commit Notification 2021-09-03 15:42:54 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1c0965148edb2a053e8e4a6762d917326fc332a2

tdf#143215 sw: test tracked deletion of empty table rows

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.