Bug 143303 - Libreoffice does not print text on PDF or printer on Lubuntu 20.04.2
Summary: Libreoffice does not print text on PDF or printer on Lubuntu 20.04.2
Status: RESOLVED DUPLICATE of bug 125234
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-11 20:52 UTC by Marco Sulla
Modified: 2021-07-13 17:35 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
test document (116.14 KB, application/vnd.oasis.opendocument.text)
2021-07-11 20:53 UTC, Marco Sulla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Sulla 2021-07-11 20:52:31 UTC
Description:
As title. See steps.


Steps to Reproduce:
1. install Lubuntu 20.04.2
2. add Libreoffice 7 ppa
3. upgrade libreoffice
4. write some text and insert an image in a document
5. export to PDF or print to a printer

Actual Results:
Image is displayed/printed, the text not

Expected Results:
Guess what?


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
I attach an example document. This document is very old, I remember I was able to print with old versions (I do not remember what version). 

Anyway I tested it also with a new, blank document. I also tested it before the upgrade to LibreOffice 7
Comment 1 Marco Sulla 2021-07-11 20:53:36 UTC
Created attachment 173495 [details]
test document
Comment 2 [REDACTED] 2021-07-11 22:38:30 UTC
Seems to be a known problem of Ubuntu 20.04 based system, which never completely removed LibreOffice. Please perform the following procedure:

1. dpkg --list | awk '/ii/&&/libreoffice/{print $2}' | sudo xargs apt purge -y ure
2. sudo apt autoremove
3. sudo apt install libreoffice

See also: https://ask.libreoffice.org/en/question/242188/cannot-print-anything-exporting-to-pdf-produces-blank-pdf-lubuntu-2004/

From my perspective a bug of Ubuntu 20.04 initial installs and not a bug of LibreOffice.
Comment 3 Marco Sulla 2021-07-12 06:57:28 UTC
> Seems to be a known problem of Ubuntu 20.04 based system

A bug in Launchpad exists? Must I open it?
Comment 4 [REDACTED] 2021-07-12 08:11:33 UTC
(In reply to Marco Sulla from comment #3)
> > Seems to be a known problem of Ubuntu 20.04 based system
> 
> A bug in Launchpad exists? Must I open it?

No - from my perspective it is not a bug in Launchpad PPA but Ubuntu's initial installation of version 20.04 in conjunction with initial installation of LibreOffice. The same procedure mentioned in my comment#2 worked to fix the same issue with LibreOffice installe from Ubuntu's base operating system repositories. There must be some inconsistency in libraries which obviously get fixed with step 2. from the procedure provided (i.e. "sudo apt autoremove") and a subsequent re-installation, if there is no LibreOffice installed at the time of executing step 2.(that's why step 1. is required). Once done it should never happen again on any update of LibreOffice regardless of the repository being used.

Please provide a feedback whether the procedure fixes the issue for you as well. 

I'm pretty sure this is not a LibreOffice bug.
Comment 5 Marco Sulla 2021-07-12 10:00:05 UTC
For Launchpad I mean the Launchpad for Ubuntu bugs, not pro Libreoffice :) There exists already a bug for this problem or I must open it?

PS: the procedure worked, now I can print text :D
Comment 6 [REDACTED] 2021-07-12 13:32:03 UTC
Set the bug to WORKSFORME, since the procedure worked for you as well.
Comment 7 [REDACTED] 2021-07-12 13:37:39 UTC
(In reply to Marco Sulla from comment #5)
> For Launchpad I mean the Launchpad for Ubuntu bugs, not pro Libreoffice :)
> There exists already a bug for this problem or I must open it?
> 

I can't tell you anything about Ubuntu bugs, but this is definitely not related to LibreOffice, neither the packages provided by TDF nor those provided by PPAs.
Comment 8 Timur 2021-07-13 17:35:43 UTC
Please search open and closed bugs before reporting. 
Another good practice is to try current Lo, which is 7.1  now where this should be fixed.

*** This bug has been marked as a duplicate of bug 125234 ***