Bug 143328 - FILESAVE: All 3 form controls disappear on reopen in LO, incorrect in MSO
Summary: FILESAVE: All 3 form controls disappear on reopen in LO, incorrect in MSO
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: implementationError
Depends on:
Blocks: XLSX-Form-Controls
  Show dependency treegraph
 
Reported: 2021-07-13 06:33 UTC by Gülşah Köse
Modified: 2021-09-22 13:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample.xlsx (139.27 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2021-07-13 06:33 UTC, Gülşah Köse
Details
Spreadsheet with form controls (19.82 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2021-07-14 11:44 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gülşah Köse 2021-07-13 06:33:56 UTC
Created attachment 173521 [details]
sample.xlsx

1) Open sample.xlsx
2) Save as sample2.xlsx

Expected: We should see "PUZZLE" button on the first sheet.
Actual: "PUZZLE" button is disappeared.

Additional info: Document reported in tdf#34941 for another reason that seems as resolved fixed.
Comment 1 Regina Henschel 2021-07-13 09:20:28 UTC Comment hidden (obsolete)
Comment 2 NISZ LibreOffice Team 2021-07-13 15:48:04 UTC
I can't open it in Excel either.

File was saved last from Excel 12 and contains in Calc a VML pushbutton on the first sheet.
Comment 3 V Stuart Foote 2021-07-14 03:27:12 UTC Comment hidden (obsolete)
Comment 4 Gülşah Köse 2021-07-14 04:38:36 UTC
Unfortunately, I didn't produce that document. I'm working on a tool that detects problems of existing files on bugzilla. You can see the tool in  feature/ooxml-analyze breach of core repo. That one is one of the output of the tool.
Comment 5 Jan Holesovsky 2021-07-14 09:05:15 UTC Comment hidden (obsolete)
Comment 6 Gülşah Köse 2021-07-14 09:36:10 UTC Comment hidden (obsolete)
Comment 7 Regina Henschel 2021-07-14 11:39:34 UTC
It is reproducible with a newly created spreadsheet. The problem in "sample.xlsx" is because of macros. I will attach another spreadsheet from Excel.

It is likely duplicate to some bugs listed in bug 133999 or its duplicates.
Comment 8 Regina Henschel 2021-07-14 11:44:59 UTC
Created attachment 173557 [details]
Spreadsheet with form controls

The spreadsheet contains a button, a check box linked to a cell, and a slider linked to a cell.
The form controls work after file open and are gone after file save and reopen in LO.
Opening the file saved by LO in Excel shows duplicate button and checkbox, and empty frame, where the slider should be.