Bug 143391 - Styles Preview scrollbar not working
Summary: Styles Preview scrollbar not working
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.beta1+
Hardware: All Linux (All)
: medium minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.3.0 target:7.2.3
Keywords:
: 142366 144581 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-07-15 14:53 UTC by Rafael Lima
Modified: 2021-10-05 09:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screencast showing the bug (861.19 KB, video/x-matroska)
2021-07-15 14:53 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2021-07-15 14:53:43 UTC
Created attachment 173606 [details]
Screencast showing the bug

The new Styles Preview introduced in LO 7.2 has a vertical scrollbar. However, it does not seem to be working correctly (see attached video).

The problem seems to happen when I scroll up. When I scroll down, all seems right.

System info:
Version: 7.2.0.1 / LibreOffice Community
Build ID: 32efc3b7f3a71cfa6a7fa3f6c208333df48656cc
CPU threads: 16; OS: Linux 5.11; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: threaded
Comment 1 Buovjaga 2021-07-17 15:17:59 UTC
Repro

NixOS
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: b1df9c67349cf4cc5be4128d797aefb87f50e38f
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: x11
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Comment 2 Justin L 2021-10-04 05:04:16 UTC
I could not reproduce this in Ubuntu 20.04 / gtk3, but I did reproduce it with SAL_USE_VCLPLUGIN=gen instdir/program/soffice.

Prior to 7.2, this had two arrows to shift the displayed styles. It was changed to IconView by commit fd9b52502de6044a2249ff81407ac579a35ad3a1
Author: Szymon Kłos  on Tue Feb 2 16:12:55 2021 +0100
    tdf#139429 Convert Style previews widget to IconView

    - this adds labels to easily identify the styles
    - easier to work with many styles
    - nice native widget in gtk3
    - double click opens the style settings
    - added Command callback from iconview
Comment 3 Caolán McNamara 2021-10-04 14:28:54 UTC
For some reason, for which I'm not quite sure yet why, the output seems to be clipped out on scrolling up.
Comment 4 Commit Notification 2021-10-04 19:43:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5a930d4b33e6b5e6642c936cb643c2c5605d6110

Resolves: tdf#143391 scrolling by an entry height taller than visible area

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2021-10-04 20:02:46 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b845fc51bb5c40eac121bbe52d8c77257bcbcdf3

Related: tdf#143391 avoid creatinging a negative height for the scroll area

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2021-10-04 20:03:20 UTC
that seems to be the problem, fixed in trunk, backport to 7-2 in gerrit
Comment 7 Commit Notification 2021-10-05 08:29:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/2af7baa30da250a6f6894175e9fda130554eb4ac

Resolves: tdf#143391 scrolling by an entry height taller than visible area

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Buovjaga 2021-10-05 09:12:58 UTC
*** Bug 144581 has been marked as a duplicate of this bug. ***
Comment 9 Buovjaga 2021-10-05 09:13:05 UTC
*** Bug 142366 has been marked as a duplicate of this bug. ***
Comment 10 Buovjaga 2021-10-05 09:20:11 UTC
Verified with kf5 and gen, thanks!

Arch Linux 64-bit
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 2d9eddbb23625aad7a9accedbf69209a04169f00
CPU threads: 8; OS: Linux 5.14; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 5 October 2021