Bug 143456 - FILEOPEN: DOCX: Endnotes are at the end of each page instead of at the end of the document
Summary: FILEOPEN: DOCX: Endnotes are at the end of each page instead of at the end of...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 143710 (view as bug list)
Depends on:
Blocks: DOCX-Footnote-Endnote
  Show dependency treegraph
 
Reported: 2021-07-20 10:41 UTC by Xisco Faulí
Modified: 2021-08-10 13:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Comparison LibreOffice 7.3 master and MSO 2010 (397.54 KB, image/png)
2021-07-20 10:41 UTC, Xisco Faulí
Details
The example document in Word 19 (136.05 KB, image/png)
2021-07-20 11:35 UTC, NISZ LibreOffice Team
Details
The example file saved as doc (665.50 KB, application/msword)
2021-07-20 12:01 UTC, NISZ LibreOffice Team
Details
The doc version of the example file in Word and Writer 7.1 (323.68 KB, image/png)
2021-07-20 12:03 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2021-07-20 10:41:32 UTC
Created attachment 173703 [details]
Comparison LibreOffice 7.3 master and  MSO 2010

Steps to reproduce:
1. Open attachment 101279 [details] from bug 80175

-> Go to page 2, page 3 or any page with references to endnotes. The endnotes are in those pages instead of at the end of the document. See comparison image

Reproduced in

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: c6695a4aabeaae99174b7658f2b813788ecff7f0
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2021-07-20 10:42:26 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=f9982c24066d6dd2f938cc20176af0f196bc018f

author	Gabor Kelemen <kelemen.gabor2@nisz.hu>	2021-07-07 00:38:46 +0200
committer	László Németh <nemeth@numbertext.org>	2021-07-13 10:45:19 +0200
commit f9982c24066d6dd2f938cc20176af0f196bc018f (patch)
tree 7b971ed9008953ab221cb1b733772c33fc441798
parent d65f6ba081817772ccce79d31fcdea38da2037ec (diff)
tdf#58521 DOCX import: enable ContinuousEndnotes compat flag

Bisected with: bibisect-linux64-7.3

Adding Cc: to Gabor Kelemen
Comment 2 NISZ LibreOffice Team 2021-07-20 11:35:37 UTC Comment hidden (obsolete)
Comment 3 Xisco Faulí 2021-07-20 11:43:21 UTC
(In reply to NISZ LibreOffice Team from comment #2)
> Created attachment 173707 [details]
> The example document in Word 19
> 
> Interesting... my Word 2019 dumps all endnotes at the end of the document
> (duh!).
> Maybe its behavior changed over time and we need to limit this setting to
> compatibilitymode < 15

Same in Word 2010, all the endnotes are at the end of the document. However, in LibreOffice, they are at the end of each page.
Comment 4 NISZ LibreOffice Team 2021-07-20 12:01:40 UTC
Created attachment 173708 [details]
The example file saved as doc
Comment 5 NISZ LibreOffice Team 2021-07-20 12:03:50 UTC
Created attachment 173709 [details]
The doc version of the example file in Word and Writer 7.1

The same happens in older versions when the example document is saved as doc.
This makes sense as the compat option was already there for doc format.
So this more like exposed a limitation in the previously made layout.
Comment 6 NISZ LibreOffice Team 2021-07-20 12:26:48 UTC
For doc this started in 6.4. In 6.3 all endnotes were on a new page at the end of the document.
Comment 7 NISZ LibreOffice Team 2021-07-20 12:31:14 UTC
About doc format see also bug 143445
Comment 8 Timur 2021-07-26 12:36:48 UTC Comment hidden (obsolete)
Comment 9 NISZ LibreOffice Team 2021-08-04 07:04:56 UTC
*** Bug 143710 has been marked as a duplicate of this bug. ***