Bug 143522 - SAVE AS HTML: Text highlight in a docx-file gets lost
Summary: SAVE AS HTML: Text highlight in a docx-file gets lost
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.4.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HTML-Export
  Show dependency treegraph
 
Reported: 2021-07-24 01:14 UTC by Javier O. Cordero Pérez (Cuperino)
Modified: 2021-08-09 17:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test input documents (22.29 KB, application/gzip)
2021-07-24 01:14 UTC, Javier O. Cordero Pérez (Cuperino)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Javier O. Cordero Pérez (Cuperino) 2021-07-24 01:14:40 UTC
Created attachment 173816 [details]
Test input documents

- Issue -
Importing DOCX, DOC, and AbiWord files with highlights and then exporting as HTML results in highlights missing from export.

- Expected behavior -
Exporting a document with highlights should result in those highlights being preserved within the HTML code.

- Other relevant details -
Exporting highlights from native ODT document results in expected behavior, which leads me to believe this may be a problem in formatting imports.

- On this test -
+ Documents where created and formatted from their respective editors. Nothing was copy pasted from program to another.
+ DOCX and DOC document were created using WPS Office Writer 2019 (11.1.0.10161)
+ AbiWord document was created using AbiWord (3.0.2)
+ ODT document was created using LibreOffice Writer (7.1.5.2)
+ OS used: Ubuntu 20.04 LTS variant

- Related Bugs -
+ 95860 documents that have paragraph text background lose that highlighting when save-as to HTML
+ 94088 FILESAVE: paragraph background colour not saved in HTML file
+ 74115 FILEOPEN, FILESAVE: [DOCX] Chart Wall with Gradient Fill, Bitmap Fill, Pattern Fill is not imported correctly, and exported back to DOCX
Comment 1 Dieter 2021-08-09 17:13:28 UTC
I confirm it with

Version: 7.2.0.1 (x64) / LibreOffice Community
Build ID: 32efc3b7f3a71cfa6a7fa3f6c208333df48656cc
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Additional informations:
File => Export => XHTML works as expected