Bug 143545 - LibreOffice logo in Windows crapped out. Again.
Summary: LibreOffice logo in Windows crapped out. Again.
Status: RESOLVED DUPLICATE of bug 136633
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-26 13:21 UTC by xordevoreaux
Modified: 2021-07-26 18:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screencap of logo (2.06 KB, image/png)
2021-07-26 13:21 UTC, xordevoreaux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xordevoreaux 2021-07-26 13:21:34 UTC
Description:
Seems to be a perennial problem with the LibreOffice Logo, at least in Windows, being badly scaled / not vectored / not anti-aliased. Looks like crap.

Steps to Reproduce:
1. Open windows LibreOffice
2. Examine the logo either in the lower left of the screen or the help page
3. Cringe

Actual Results:
Logo looks like crap.

Expected Results:
Logo should not be cringe-worthy.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 2a151d1d5bc055d5e0011460b6ec42ea9f34f880
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 1 xordevoreaux 2021-07-26 13:21:59 UTC
Created attachment 173855 [details]
screencap of logo
Comment 2 Julien Nabet 2021-07-26 13:55:32 UTC
Since LO indicates it uses Skia Vulkan, could you give a try at https://wiki.documentfoundation.org/QA/FirstSteps#Graphics-related_issues_.28Skia.29 ?
Comment 3 xordevoreaux 2021-07-26 15:28:36 UTC
(In reply to Julien Nabet from comment #2)
> Since LO indicates it uses Skia Vulkan, could you give a try at
> https://wiki.documentfoundation.org/QA/FirstSteps#Graphics-related_issues_.
> 28Skia.29 ?

No better this way with Skia forced:

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 2a151d1d5bc055d5e0011460b6ec42ea9f34f880
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL



And no better this way with no Skia just hardware acceleration:

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 2a151d1d5bc055d5e0011460b6ec42ea9f34f880
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: default; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 4 Julien Nabet 2021-07-26 15:33:08 UTC
Thank you for your feedback.
Since I don't have more question, I'll put it back to UNCONFIRMED.
Comment 5 V Stuart Foote 2021-07-26 18:52:14 UTC
dupe of bug 136633, and see also 139085

The logos are SVG now.  Worse without antialiasing, but the SVG used for logo is not well rendered at normal HD scale.

*** This bug has been marked as a duplicate of bug 136633 ***