Bug 143608 - FILESAVE: Comment resolution status is not being saved in .docx format
Summary: FILESAVE: Comment resolution status is not being saved in .docx format
Status: RESOLVED DUPLICATE of bug 122222
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-29 15:58 UTC by Ty Mick
Modified: 2021-07-30 15:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ty Mick 2021-07-29 15:58:10 UTC
Description:
After resolving a comment, saving the file, closing, and reopening, the comment is no longer resolved.

I know that resolving comments is a thing that can be saved in .docx with Microsoft Word, because I am working with a team that uses Microsoft Word and Microsoft Teams, and the integrated Word editor in Teams lets you resolve comments, and it saves the comment resolution status there.

When I resolve a comment in the Word editor in Teams, then download the .docx file and open it in LibreOffice, it still doesn't show as resolved. That means that LibreOffice is unable to read the comment resolution status from a .docx file. And when I resolve a comment in LibreOffice, save the file as .docx, then open the file in the Word editor in Teams, the comment still doesn't show as resolved. That means that LibreOffice is unable to write the comment resolution status in the 

Steps to Reproduce:
1. Edit a .docx file in LibreOffice Writer.
2. If there aren't already any comments in the document, create a new one.
3. Resolve a comment by clicking its dropdown button and then clicking either "Resolve" or "Resolve Thread".
4. Note that the comment box now displays the word "Resolved".
5. Note that the comment's dropdown menu now shows an "Unresolve" option where the "Resolve" option used to be.
6. Save the file.
7. Close the file.
8. Open the same file.

Actual Results:
The comment is no longer resolved, as evidenced by the absence of the word "Resolved" in the comment box and the presence of a "Resolve" option in the comment's dropdown menu instead of "Unresolve".

Expected Results:
The comment should still be resolved after reopening the saved file.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.1.5.2 / LibreOffice Community
Build ID: 85f04e9f809797b8199d13c421bd8a2b025d52b5
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

I don't think this would have an effect, but since I didn't check "Is OpenGL enabled?" below, the option for "Use OpenGL for all rendering" does not show up for me when I go to LibreOffice ▸ Preferences ▸ LibreOffice ▸ View. But under "Graphics Output" there, a "Use hardware acceleration" option is disabled and unchecked, and a "Use anti-aliasing" option is checked.
Comment 1 Timur 2021-07-30 09:02:42 UTC
I didn't test but should be duplicate. 
Please note that before reporting you should either search bugs if already reported or/and test master from https://dev-builds.libreoffice.org/daily/master/current.html.
Please confirm with master, that should be separate to your working LO.

*** This bug has been marked as a duplicate of bug 122222 ***
Comment 2 Ty Mick 2021-07-30 15:01:09 UTC
(In reply to Timur from comment #1)
> I didn't test but should be duplicate. 
> Please note that before reporting you should either search bugs if already
> reported[...]

Thanks for catching the duplicate, Timur. I only searched for "comment resolution" and "comment resolved" before posting--didn't think to search with the word "done" since that's not the word used in the UI.
Comment 3 Ty Mick 2021-07-30 15:04:31 UTC
For anyone else who finds this bug before the one it duplicates, it looks like this will be fixed in version 7.2. 🎉