Bug 143633 - Image size set to 0,04 cm after disabling relative image width
Summary: Image size set to 0,04 cm after disabling relative image width
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.3.0 target:7.2.1
Keywords: bibisected, bisected, regression
: 143590 144068 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-07-31 08:10 UTC by Telesto
Modified: 2023-03-12 21:44 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-07-31 08:10:12 UTC
Description:
Image size set to 0,04 cm after disabling relative image width

Steps to Reproduce:
1. Open attachment 173985 [details]
2. Right click the image -> Properties (or F4)
3. Type tab
4. Check keep ratio
5. Check set relative to (to paragraph)
6. Press OK
7. F4
8. Uncheck Check set relative to (to paragraph)

Actual Results:
0,04 shows

Expected Results:
I would expect the original image size (so based on actual size on screen) surely not 0,04


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 2a151d1d5bc055d5e0011460b6ec42ea9f34f880
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2021-07-31 08:12:00 UTC
At least not 0,04 with (broken in another way)
Version: 7.1.0.0.beta1+ (x64)
Build ID: f9fab4203c1aa0b9a3f27ce2713b6d5addc7df19
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: nl-NL
Calc: CL
Comment 2 Dmitrii A 2021-08-03 02:36:26 UTC
Confirm in

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: ac80ec817eb07c77a51bc0729985a473c734182e
CPU threads: 16; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL
Comment 3 raal 2021-08-04 14:46:34 UTC
This seems to have begun at the below commit.
Adding Cc: to Heiko Tietze ; Could you possibly take a look at this one?
Thanks
 3cbecf3d0d9d68de286589e153ee31f8f709be03 is the first bad commit
commit 3cbecf3d0d9d68de286589e153ee31f8f709be03
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Sun Feb 21 10:16:41 2021 +0100

    source eb807e785b6acda1529b2f58ada2c1e84b38f7f5

https://git.libreoffice.org/core/+/eb807e785b6acda1529b2f58ada2c1e84b38f7f5
     Resolves tdf#140511 - UI glitches
Comment 4 Commit Notification 2021-08-24 12:31:24 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/dd5039ceea319ebfc72a3e032753b22538add12e

Resolves tdf#143633 - Image size wrong after disabling relative image width

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2021-08-25 15:10:09 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/66e505fba39dc1c7663e157cc76544f2547b0b17

Resolves tdf#143633 - Image size wrong after disabling relative image width

It will be available in 7.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Buovjaga 2021-08-28 14:13:22 UTC
*** Bug 143590 has been marked as a duplicate of this bug. ***
Comment 7 Buovjaga 2021-08-28 14:13:34 UTC
*** Bug 144068 has been marked as a duplicate of this bug. ***