Bug 143659 - FORMATTING: Cells formatted as shrink to Cell Size won't show the whole content.
Summary: FORMATTING: Cells formatted as shrink to Cell Size won't show the whole content.
Status: RESOLVED DUPLICATE of bug 143978
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.0.2 rc
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2021-08-01 07:53 UTC by Robert Großkopf
Modified: 2021-10-19 10:04 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Shows difference between shown content and real content of the cell. (32.53 KB, image/png)
2021-08-01 07:53 UTC, Robert Großkopf
Details
7.2.2.2 with various font sizes (107.34 KB, image/jpeg)
2021-10-16 10:46 UTC, Tamo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2021-08-01 07:53:42 UTC
Created attachment 174004 [details]
Shows difference between shown content and real content of the cell.

Open https://bugs.documentfoundation.org/attachment.cgi?id=70231 from bug 57257 with LO 7.2.0.2. There are two cells with content, which is formatted as shrink to cell size. The content, which will be shown in the cell, isn't the whole content of the cell. See the attached screenshot. There will be only shown the text, which could also be seen when typing in the cell without shrinking.

Tested with 
Version: 7.2.0.2 / LibreOffice Community
Build ID: 614be4f5c67816389257027dc5e56c801a547089
CPU threads: 6; OS: Linux 5.3; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Calc: threaded

(OpenSUSE 15.2 64bit rpm Linux)
Comment 1 m.a.riosv 2021-08-01 12:53:08 UTC
Repro
Version: 7.2.0.0.beta1+ (x64) / LibreOffice Community
Build ID: 8b496beb74255d619a8de72a07860d1a77c4f79a
CPU threads: 4; OS: Windows 10.0 Build 21390; UI render: Skia/Vulkan; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: CL

Works fine 
Version: 7.1.5.2 (x64) / LibreOffice Community
Build ID: 85f04e9f809797b8199d13c421bd8a2b025d52b5
CPU threads: 4; OS: Windows 10.0 Build 21390; UI render: Skia/Raster; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: CL
Comment 2 raal 2021-08-06 21:29:45 UTC
The text is missing in gtk3. This seems to have begun at the below commit.
Adding Cc: to Luboš Luňák ; Could you possibly take a look at this one?
Thanks
linux-64-7.2$  856217b04de9b5dc5b0b6758f6eb0f4dd728c941 is the first bad commit
commit 856217b04de9b5dc5b0b6758f6eb0f4dd728c941
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Jan 21 18:23:08 2021 +0100

    source d62ad3efe3c8778cfda00799f1cd7bb3349e0b75

https://git.libreoffice.org/core/+/d62ad3efe3c8778cfda00799f1cd7bb3349e0b75
  cache SalLayoutGlyphs in ScOutputData::LayoutStrings()
Comment 3 Tamo 2021-10-16 10:46:09 UTC
Created attachment 175776 [details]
7.2.2.2 with various font sizes

7.2.2.2 still has this bug.
Increasing the font size makes the situation even worse.
See the screenshot.
Comment 4 Luboš Luňák 2021-10-19 10:04:48 UTC

*** This bug has been marked as a duplicate of bug 143978 ***