Bug 143686 - Text is cut off in window during installation, when a program like Firefox is still running
Summary: Text is cut off in window during installation, when a program like Firefox is...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
7.2.0.2 rc
Hardware: All All
: medium normal
Assignee: Roman Kuznetsov
URL:
Whiteboard: target:7.3.0 target:7.2.0 target:7.2.3
Keywords:
: 143742 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-08-02 08:47 UTC by Klaus1189
Modified: 2021-10-20 05:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot (108.29 KB, image/png)
2021-08-02 08:47 UTC, Klaus1189
Details
7.2.1.1 still affected (107.24 KB, image/png)
2021-09-11 10:28 UTC, Klaus1189
Details
another window (27.52 KB, image/png)
2021-10-09 13:49 UTC, Klaus1189
Details
7.2.2.2 still affected (97.33 KB, image/png)
2021-10-09 13:49 UTC, Klaus1189
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Klaus1189 2021-08-02 08:47:18 UTC
Created attachment 174023 [details]
screenshot

If you install 7.2.0.2 on Windows 10 and in my case I forgot to close Firefox, then there pops up a widnow where the text is cut off.
I use a 3840x2160p screen with 200 % scaling.

I don't know the earliest affected version.

I beg to increase the label in this window, so the text fits.
Comment 1 Commit Notification 2021-08-04 16:31:22 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/af0437d7b1d9cc5a00b7d01a6510e5ba40ca1a12

tdf#143686 Increase a width of the label

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Roman Kuznetsov 2021-08-04 16:41:52 UTC
backport to 7.2 is in gerrit
Comment 3 Commit Notification 2021-08-04 18:36:24 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/df389c813637f7681fccf025a624554b3627468e

tdf#143686 Increase a width of the label

It will be available in 7.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Julien Nabet 2021-08-05 12:09:53 UTC
*** Bug 143742 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2021-08-09 07:42:28 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "libreoffice-7-2-0":

https://git.libreoffice.org/core/commit/07f3b01f84e2540a7e40244b8efff969d9f6107c

tdf#143686 Increase a width of the label

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Klaus1189 2021-08-12 17:21:18 UTC
I just tested 7.2.0.3 and it seems the patch is not included, right?
Comment 7 Roman Kuznetsov 2021-08-12 17:51:33 UTC
(In reply to Klaus1189 from comment #6)
> I just tested 7.2.0.3 and it seems the patch is not included, right?

So strange. Can you do a screenshot in 7.2.0.3 and compare with the screenshot attached in the report here?
Comment 8 Klaus1189 2021-08-12 18:19:15 UTC
I am trying to get the message again, but no luck. Many repair installations of LibreOffice, restarts, ... later still the same. I can not trigger the message window despite the fact Firefox is running. Do I need to do anything special in Firefox so this message shows up?

I am the bug reporter and the issue looks very similar, I add a new screenshot as soon I can get this window to open.

3840x2160p with 200% scaling in windows.

Stay tuned, I am trying ...
Comment 9 Klaus1189 2021-08-12 18:35:51 UTC
I can not rigger the window, is there a small test build that opens only this window? Would save me time. I can not trigger it.
Comment 10 Roman Kuznetsov 2021-08-12 19:03:45 UTC
(In reply to Klaus1189 from comment #9)
> I can not rigger the window, is there a small test build that opens only
> this window? Would save me time. I can not trigger it.

Let's just wait if you'll see the problem again in 7.2.1, for example. Then will write here again
Comment 11 Klaus1189 2021-09-11 10:28:06 UTC
I just installed 7.2.1.1, well no I paused at the screen and leav it in the background for now.

Issue is still present in 7.2.1.1
I add a new screenshot here.
Comment 12 Klaus1189 2021-09-11 10:28:56 UTC
Created attachment 174969 [details]
7.2.1.1 still affected
Comment 13 Roman Kuznetsov 2021-09-11 18:29:33 UTC
Interesting, let me do some investigation
Comment 14 Klaus1189 2021-10-09 13:49:39 UTC
Created attachment 175611 [details]
another window
Comment 15 Klaus1189 2021-10-09 13:49:58 UTC
Created attachment 175612 [details]
7.2.2.2 still affected
Comment 16 Klaus1189 2021-10-09 13:51:33 UTC
7.2.2.2 is still affected :(
Versions between 7.2.1.1 and 7.2.2.2, like 7.2.1.2 showed another window. I added a screenshot of this window here.
7.2.2.2 screenshot is also uploaded.
Comment 17 Roman Kuznetsov 2021-10-12 12:57:36 UTC
It seems the radio button's area has its own size and if the controls have bigger size then the area size, then we see a cropped label's text.

Let's try this https://gerrit.libreoffice.org/c/core/+/123409
Comment 18 Commit Notification 2021-10-13 06:42:20 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d8a1187fc262ccb4c6489b2ca830f230400c5b82

tdf#143686 increase a radiobutton's area size

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2021-10-13 10:34:22 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/43b69fb3a63f1044288e3a49b3d822dd1b8df35c

tdf#143686 increase a radiobutton's area size

It will be available in 7.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.