Bug 143783 - Fileopen PPTX: shape shown with wrong rotation
Summary: Fileopen PPTX: shape shown with wrong rotation
Status: RESOLVED DUPLICATE of bug 45495
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
: 143863 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-08-09 09:29 UTC by Timur
Modified: 2021-08-13 23:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
PPTX compared in MSO and LO (103.79 KB, image/png)
2021-08-09 09:29 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2021-08-09 09:29:58 UTC
Created attachment 174151 [details]
PPTX compared in MSO and LO

Block shape with Continuous Block Process in PPTX attachment 170643 [details] from bug 141188 is seen pointed at 3 o'clock although it's pointed to 12 o'clock in MSO. 

I don't see how it was rotated in MSO, but Reset Graphic (remove SmartArt formatting) in MSO changes it the way LO shows it.
Wrong open regardless if shape ungrouped.

Seen from 7.3+ due to bug 132696. PPTX opened with objects from 4.0 to 6.2. Rotation was never OK in PPTX.
MSO saved PPT opens with correct rotation, as shown in attached screenshot.

When resolved, filesave as PPTX should also be tested.
Comment 1 Timur 2021-08-09 09:44:42 UTC
This is 3-D rotation / Z rotation. Let's keep as a duplicate.

*** This bug has been marked as a duplicate of bug 45495 ***
Comment 2 Gerald Pfeifer 2021-08-13 23:46:10 UTC
*** Bug 143863 has been marked as a duplicate of this bug. ***