Bug 143788 - Floating widgets don't accept clicks under kf5
Summary: Floating widgets don't accept clicks under kf5
Status: RESOLVED DUPLICATE of bug 144037
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2021-08-09 12:30 UTC by Heiko Tietze
Modified: 2021-08-24 09:36 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2021-08-09 12:30:36 UTC
With latest master I click some item in floating widgets like color pickers or dropdown lists and don't get the selected item. Color picker never takes the selection, comboboxes what has been picked before (eg. the filter in the Stylist, click on Custom (=All), List (=Custom), Hierarchy (=Custom) etc.

Using gtk3 VCL works fine.

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 6daf48b50e1ff3bdd6a9f948c3e267e76b8a89d3
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (en_US.UTF-8); UI: en-US
Calc: threaded

No problem with 

Version: 7.1.5.2 / LibreOffice Community
Build ID: 10(Build:2)
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: kf5
Locale: de-DE (en_US.UTF-8); UI: en-US
7.1.5-2
Calc: threaded
Comment 1 Buovjaga 2021-08-24 09:36:00 UTC

*** This bug has been marked as a duplicate of bug 144037 ***