Bug 143898 - Color palette and border style combo not work
Summary: Color palette and border style combo not work
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-16 10:25 UTC by Hojjatollah
Modified: 2021-09-06 18:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Style or color (2.41 MB, video/mp4)
2021-08-29 01:28 UTC, afshin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hojjatollah 2021-08-16 10:25:21 UTC
Description:
Salam
in writer 7.1.3 and 7.1.5 
Color palette and border style combo not work not work in paragraph dialogue and page dialog.

open but not clickable or selectable 

Steps to Reproduce:
1.format > page style ... on menu bar
2.Borders 
3.Color Palette

Actual Results:
no able select any color or border

Expected Results:
select any color


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
linux mint 18.3 LTS
Comment 1 Julien Nabet 2021-08-16 10:52:39 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this with gtk3 and gen renderings but could reproduce this with kf5 rendering.

Michael: thought you might be interested in this one.
Comment 2 afshin 2021-08-29 01:28:40 UTC
Created attachment 174598 [details]
Style or color

I can select any style or color, but dose not apply on page!
Please watch screencast attachment.
Comment 3 afshin 2021-08-29 01:38:53 UTC
I'm sorry. I had forgotten choose one of the "Presets" of borders. After that, selected style and color apply on page.
Comment 4 Michael Weghorn 2021-08-31 07:47:22 UTC
This works just fine for me on Debian testing with current master:

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 774bc3d64b6e1149ab9607e3fd11c96eee0da59f
CPU threads: 12; OS: Linux 5.10; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

This sounds similar to (or the same as) bug 143788, which has been closed as a duplicate of (now fixed) bug 144037.

Can you please retest either with a current daily build or with LibreOffice 7.2.2 (once it has been published)?
Comment 5 HM 2021-09-01 18:28:04 UTC
I see this bug in gtk3

export SAL_USE_VCLPLUGIN=gtk3;
Comment 6 HM 2021-09-06 17:19:30 UTC
this problem solve by update gnome or upgrade linux
error in linux min 18.3
Comment 7 Julien Nabet 2021-09-06 18:17:55 UTC
Let's rather put WFM since there's no specific LO fix for this bug.