Bug 143965 - Irresponsive box of style preview under Home tab in tabbed view
Summary: Irresponsive box of style preview under Home tab in tabbed view
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: x86 (IA32) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 144210 (view as bug list)
Depends on:
Blocks: Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2021-08-20 03:19 UTC by mdhosamnayeem
Modified: 2021-11-06 05:41 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
previous items disappear from list of style (469.25 KB, video/mp4)
2021-11-05 11:50 UTC, medmedin2014
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mdhosamnayeem 2021-08-20 03:19:52 UTC
Description:
As i go through different types of styles available using the downward arrow at right side of the box and reach the end at 'Performance Text', the upward button which should ideally scroll me through the available options to the first simply does not word. However if i press downward arrow after pressing upward arrow the option goes directly to the first one.

Steps to Reproduce:
1.By default the first style should be selected click on downward arrow to scroll to the last option.
2. To again go back to the previous options upward arrow should work but it does not.
3.Instead after clicking the upward arrow two or more time and then clicking downward arrow the style view goes to a different one.

Actual Results:
The writer functions normally but the scrolling is not working.

Expected Results:
Scrolled through the styles available forwards and backwards in the step of number of styles currently viewable in the box. 


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 7.2.0.4 (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: en-IN (en_IN); UI: en-US
Calc: threaded
Comment 1 Dieter 2021-09-04 08:23:14 UTC
I confirm it with

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 74d35e143d557a7e65c4443f5b80cb9d406b1fa1
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL
Comment 2 V Stuart Foote 2021-09-04 13:22:58 UTC
*** Bug 144210 has been marked as a duplicate of this bug. ***
Comment 3 V Stuart Foote 2021-09-04 13:31:25 UTC
Seems the grid holding the style previews is not well served by the scroll bar now attached to its panel.

Navigating the grid of style previews works well with cursor movments L,R moves between previews while U,D moves between rows of the grid.

The thumb of the scroll bar moves grid rows up or down. The down arrow of the scroll bar moves grid row down.  The up arrow of the scroll bar does not move the grid row.

@Syzmon? A leftover from refactor done for bug 139429...
Comment 4 stragu 2021-11-05 01:41:39 UTC
I can reproduce 7.2.2.2 (the view does not refresh when pressing the up arrow in the scrollbar):

Version: 7.2.2.2 / LibreOffice Community
Build ID: 02b2acce88a210515b4a5bb2e46cbfb63fe97d56
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: x11
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

But it seems fixed in:

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 5b2848413883565c48d312c96daf8fbca25405d8
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: x11
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-10-11_23:38:53
Calc: threaded

(the scrollbar arrows work as expected).

Marking as WFM, but can someone else double-check?

Not sure if the fix can be identified and backported to 7.2 at all.
Comment 5 medmedin2014 2021-11-05 11:47:26 UTC
(In reply to stragu from comment #4)

> Marking as WFM, but can someone else double-check?

The up/down click is totally broken, and the whole style list is broken, if you select an element then it becomes first and the previous elements become not visible at all, who the hell proposed to put the select item into first position ? See attached video for more info.
Comment 6 medmedin2014 2021-11-05 11:50:53 UTC
Created attachment 176119 [details]
previous items disappear from list of style

The most important feature in LibreOffice is really broken
Comment 7 V Stuart Foote 2021-11-05 13:25:24 UTC
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 5ab21caf603ba0a1c95bbc94a29eebe3483d1599
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

The NB Tabbed UI issue of poor navigation of the Home tab's grid holding the style previews has been resolved.

Agree there is some logic issue with which style previews appear in the grid as selections are made--some styles when applied from the Sidebar Styles deck are not   added to the NB widget, while the Default para style gets removed (even though other para still have it applied). File a new fully scoped BZ issue.

But, navigation controls-- cursor (U,D, L,R) and scroll bar widget (Up, Down, Thumb) are now positioning the grid of styles consistently.

=> WFM
Comment 8 medmedin2014 2021-11-05 17:46:52 UTC
(In reply to V Stuart Foote from comment #7)

> But, navigation controls-- cursor (U,D, L,R) and scroll bar widget (Up,
> Down, Thumb) are now positioning the grid of styles consistently.
> 
> => WFM

Select any style in the middle and you will see that all styles before the current selected disappear and if you click the up button you can't see them at all.
Comment 9 V Stuart Foote 2021-11-05 21:02:52 UTC
(In reply to medmedin2014 from comment #8)
> (In reply to V Stuart Foote from comment #7)
> 
> > But, navigation controls-- cursor (U,D, L,R) and scroll bar widget (Up,
> > Down, Thumb) are now positioning the grid of styles consistently.
> > 
> > => WFM
> 
> Select any style in the middle and you will see that all styles before the
> current selected disappear and if you click the up button you can't see them
> at all.

And that is a different issue!  File a new BZ report *fully* scoped.
Comment 10 stragu 2021-11-06 05:41:34 UTC
(In reply to medmedin2014 from comment #8)
 
> Select any style in the middle and you will see that all styles before the
> current selected disappear and if you click the up button you can't see them
> at all.

medmedin2014, as Stuart said, the main issue described here (the scrolling issue) has been resolved. However, if you still observe it in a master build, please let us know (with the version details included).

The issue related to the selection jumping to the left is described in bug 141335 already. (Mentioned in the "see also" field here.)

If there is something else that needs fixing, please open a new, detailed bug report specific to one single problem. Some other improvement are listed in bug 139429 as well, and check the meta bug 107237 too to make sure you are not duplicating an existing issue.