Bug 143981 - Incorrect display of dark theme in LibreOffice
Summary: Incorrect display of dark theme in LibreOffice
Status: RESOLVED DUPLICATE of bug 118320
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-20 18:19 UTC by Екатерина
Modified: 2021-09-17 06:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Екатерина 2021-08-20 18:19:13 UTC
Description:
When you select a dark theme in LibreOffice, the color changes only in the work area, with the exception of the scroll bar and ruler. The main menu, sidebar, toolbars, scrollbars, rulers, and status bar are all displayed in a light theme.

Steps to Reproduce:
1.Click "Tools" in LibreOffice
2.Then click "Options"
3.And then "Application Colors"
4.choose in Color Scheme LibreOfficedev Dark

Actual Results:
the color changes only in the work area, with the exception of the scroll bar and ruler. The main menu, sidebar, toolbars, scrollbars, rulers, and status bar are all displayed in a light theme.

Expected Results:
color change takes place entirely in the application, including all elements: main menu, sidebar, scrollbar, status bar and work surface


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: cb2827f5f65324f309fa0e3c30d0b19ad237410e
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL
Comment 1 Екатерина 2021-08-21 12:37:41 UTC
I want to complete the playback steps: 
5.open either LibreOffice Writer or LibreOffice Calc or Impress
Comment 2 Buovjaga 2021-09-16 17:15:31 UTC
Heiko: I guess the reporter's request would only be fulfilled by true dark mode support à la bug 118320?
Comment 3 Heiko Tietze 2021-09-17 06:51:25 UTC
(In reply to Buovjaga from comment #2)
> Heiko: I guess the reporter's request would only be fulfilled by true dark
> mode support à la bug 118320?

Yes, the "Application Colors" are internal while controls should be drawn by the OS, not functional as reported in bug 118320 for Windows (and macOS on another ticket).

*** This bug has been marked as a duplicate of bug 118320 ***