Bug 144010 - Filter by Background / Text Colour does not work for cells formatted by condition
Summary: Filter by Background / Text Colour does not work for cells formatted by condi...
Status: RESOLVED DUPLICATE of bug 142579
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoFilter-Color
  Show dependency treegraph
 
Reported: 2021-08-22 22:11 UTC by John Murrell
Modified: 2021-09-06 08:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Murrell 2021-08-22 22:11:10 UTC
Description:
The latest update of LibreOffice calc introduced the ability to filter by Background or text colour which works if you manually change the cell colours.

If the Background or text colour are changed by conditional formatting this does not show in the filter selection so you cannot filter by it.



Steps to Reproduce:
1.Create a list of numbers with some duplicates
2.used the conditional format - condition to format the duplicate values as 'errors' which have white text on a red background. 
3.Apply an auto filter to the list.
4:Neither the red background or white text appear in the Text Colour or Background colour in the filter selection.

Actual Results:
Background & text colour not shown in filter selection

Expected Results:
Background & Text colour should appear in filter selector allowing cells formatted by conditional formatting to be filtered.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-GB
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes

https://gerrit.libreoffice.org/gitweb?p=core.git;a=log;h=9a9c6381e3f7a62afc1329bd359cc48accb6435b

(the rest will not copy)
Comment 1 Ming Hua 2021-08-22 23:32:00 UTC
Thanks for reporting.

The issue with supporting colors from conditional formatting has been raised in bug 142579 and bug 142580.  But since those are about XLSX compatibility specifically, I'm not marking any duplicates yet, and let the developers or senior QA people decide.
Comment 2 Samuel Mehrbrodt (allotropia) 2021-09-06 08:49:20 UTC
Yeah this should be fixed with bug 142579 and bug 142580.

*** This bug has been marked as a duplicate of bug 142579 ***
Comment 3 Samuel Mehrbrodt (allotropia) 2021-09-06 08:50:04 UTC
If it still doesn't work with the next daily build, please provide a sample document so that I can reproduce.