Bug 144036 - New icon needed for the UNO Object Inspector
Summary: New icon needed for the UNO Object Inspector
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All All
: medium normal
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.3.0 target:7.4.0 target:7.3.2
Keywords:
Depends on:
Blocks: Icon-Theme-Breeze Icon-Theme-Colibre Icon-Theme-KarasaJaga Icon-Theme-Elementary Icon-Request Icon-Theme-Sifr Icon-Theme-Sukapura
  Show dependency treegraph
 
Reported: 2021-08-23 15:18 UTC by Rafael Lima
Modified: 2022-02-20 13:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Image with the button in the tabbed interface (without icon) (45.16 KB, image/png)
2021-08-23 16:39 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2021-08-23 15:18:45 UTC
LibreOffice 7.2 introduced the new UNO Object Inspector, which currently can be accessible only via the menubar (Tools - Development Tools).

While fixing Bug 141591 to add support for the tabbed interface (notebookbar), I noticed that the command .uno:DevelopmentToolsDockingWindow does not have an associated icon.

See the attached image for more information. The image shows the current status of the patch, where no image is displayed for the command.

Is there work going on concerning the creation of an icon for the Object Inspector?

Maybe there's already an icon that can be used?
Comment 1 Rafael Lima 2021-08-23 16:39:44 UTC
Created attachment 174498 [details]
Image with the button in the tabbed interface (without icon)
Comment 2 Roman Kuznetsov 2021-08-24 06:49:19 UTC
Rizal, Andreas I think this one is for you
Comment 3 Rizal Muttaqin 2021-08-24 10:55:26 UTC
(In reply to Roman Kuznetsov from comment #2)
> Rizal, Andreas I think this one is for you

It's on me. Any idea how it should look like? Firefox just use plain wrench icon but it's too generic IMHO (and overlapping with "settings/configure" icon)
Comment 4 Rafael Lima 2021-08-24 21:56:54 UTC
> It's on me. Any idea how it should look like? Firefox just use plain wrench
> icon but it's too generic IMHO (and overlapping with "settings/configure"
> icon)

Hi Rizal! Creating icons is not my expertise, but I was thinking of using a magnifier and something resembling an object or document.

Something like this:
https://www.onlinewebfonts.com/icon/488943

But also with the concept of an object:
https://thenounproject.com/term/object/2355513/
Comment 5 Rizal Muttaqin 2021-08-25 01:30:47 UTC
(In reply to Rafael Lima from comment #4)
> 
> Hi Rizal! Creating icons is not my expertise, but I was thinking of using a
> magnifier and something resembling an object or document.

We have already such kind of icon for "Print Preview", so I would not like to pick that. After a bit research, I would prefer something related to development like hammer.

@AndreasKainz what do you think?
Comment 6 andreas_k 2021-08-25 06:21:45 UTC
(In reply to Rizal Muttaqin from comment #5)
> (In reply to Rafael Lima from comment #4)
> > 
> > Hi Rizal! Creating icons is not my expertise, but I was thinking of using a
> > magnifier and something resembling an object or document.
> 
> We have already such kind of icon for "Print Preview", so I would not like
> to pick that. After a bit research, I would prefer something related to
> development like hammer.
> 
> @AndreasKainz what do you think?

good point LibO has a lot of paper icons, so yes a hammer is cool.
Comment 7 Commit Notification 2021-10-20 09:53:14 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/317b9f31231cadc740cf23cc4d7c8e2b24324825

Breeze: tdf#144036 UNO Object Inspector icons

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2021-11-14 21:31:46 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/abe18bae182fd43d16a6371d2df061565dadcd8a

elementary: tdf#144036 add UNO Object Inspector

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2021-11-15 04:14:57 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6f3f033f91a2debe064d4cd127e9f31cf2518db1

KJ: tdf#144036 add UNO Object Inspector

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-11-16 04:46:01 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b40877d31e8d7d0102ac7dedc67eb6e91067d27d

Colibre: tdf#144036 add UNO Object Inspector

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2021-11-17 06:13:08 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8a323e6904beba41dfdf054fcbaeac1d44fabc1e

Sifr: tdf#144036 add UNO Object Inspector

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 BogdanB 2022-01-28 06:27:29 UTC
Hi, what is the status of this bug, seems solved, but in 7.4 I can't see an icon on the right, like in comment 1.

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 2f4f4cbeb8e50081d607b86b0475b93971c40ab8
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 13 Rizal Muttaqin 2022-01-28 09:08:58 UTC
(In reply to BogdanB from comment #12)
> Hi, what is the status of this bug, seems solved, but in 7.4 I can't see an
> icon on the right, like in comment 1.
> 
> Version: 7.4.0.0.alpha0+ / LibreOffice Community
> Build ID: 2f4f4cbeb8e50081d607b86b0475b93971c40ab8
> CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: gtk3
> Locale: ro-RO (ro_RO.UTF-8); UI: en-US
> Calc: threaded

All icon themes have gotten the icons except Sukapura.

Mine is OK

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 4a388f5e01ebb5a512931d11e48c4380382239c8
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: id-ID (id_ID.UTF-8); UI: id-ID
Calc: threaded
Comment 14 Rafael Lima 2022-02-18 17:14:40 UTC
FIXED. Tested in:

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 60f786bde4524bbba462eccc6578715f39020076
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: CL
Comment 15 Rizal Muttaqin 2022-02-19 01:39:46 UTC
Reopened, since Sukapura has not got the icon
Comment 16 Commit Notification 2022-02-20 11:21:52 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2b80f5a1646308ed43d1d7fee6ce3cefdc9e05e3

Sukapura: tdf#144036 add UNO Object Inspector icons

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2022-02-20 13:07:33 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/c31010c7d62182becf8da3a96aad7011c82e2939

Sukapura: tdf#144036 add UNO Object Inspector icons

It will be available in 7.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.