Bug 144037 - kf5: Unable to insert table from toolbar button
Summary: kf5: Unable to insert table from toolbar button
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 143788 144441 144458 144485 144499 144562 144567 144569 144580 144655 144739 144742 144857 144873 144956 144974 145704 (view as bug list)
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2021-08-23 17:49 UTC by Buovjaga
Modified: 2021-11-18 20:07 UTC (History)
25 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (5.75 KB, text/plain)
2021-10-08 11:12 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2021-08-23 17:49:05 UTC
1. Open Writer
2. Try to insert a table from the toolbar button

Bibisected with linux-64-7.3 to
https://git.libreoffice.org/core/commit/9dcf5816c90e9819861332f11e014ef7b78e2fe7
tdf#143580 Qt5 don't use Qt::Popup for FLOAT wins

Adding Cc: to Jan-Marek Glogowski
Comment 1 Roman Kuznetsov 2021-08-24 08:11:02 UTC
I think bug 143788 is about the same
Comment 2 Buovjaga 2021-08-24 09:36:00 UTC
*** Bug 143788 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2021-08-26 16:00:09 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a1a83b6b3b4459de353e0cdc8cdf402370c0a5c4

tdf#144037 Qt5 just close popup with mouse outside

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Buovjaga 2021-08-26 17:23:13 UTC
Verified, thanks!

Arch Linux 64-bit
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: a1a83b6b3b4459de353e0cdc8cdf402370c0a5c4
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 26 August 2021
Comment 5 Commit Notification 2021-08-27 03:41:24 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/7c1f4284562e905372b5c14b6017f1eb438f54b5

tdf#144037 Qt5 just close popup with mouse outside

It will be available in 7.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Michael Weghorn 2021-09-14 06:08:06 UTC
*** Bug 144458 has been marked as a duplicate of this bug. ***
Comment 7 Jan-Marek Glogowski 2021-09-15 12:15:00 UTC
*** Bug 144485 has been marked as a duplicate of this bug. ***
Comment 8 Buovjaga 2021-09-17 06:54:45 UTC
*** Bug 144562 has been marked as a duplicate of this bug. ***
Comment 9 Jan-Marek Glogowski 2021-09-17 09:46:38 UTC
FWIW: the patch also applies to 7.2.1. I somehow missed to backport it. There was https://gerrit.libreoffice.org/c/core/+/122116, but too late :-(
Comment 10 Xisco Faulí 2021-09-17 12:00:58 UTC
*** Bug 144567 has been marked as a duplicate of this bug. ***
Comment 11 Jan-Marek Glogowski 2021-09-17 13:37:51 UTC
*** Bug 144569 has been marked as a duplicate of this bug. ***
Comment 12 Buovjaga 2021-09-18 09:44:30 UTC
*** Bug 144580 has been marked as a duplicate of this bug. ***
Comment 13 Rizal Muttaqin 2021-09-20 00:40:48 UTC
(In reply to Jan-Marek Glogowski from comment #9)
> FWIW: the patch also applies to 7.2.1. I somehow missed to backport it.
> There was https://gerrit.libreoffice.org/c/core/+/122116, but too late :-(

So, any chance 7.2.1 will be patched? This bug affects many UI elements which make LibO barely usable in kf5.
Comment 14 Michael Weghorn 2021-09-20 06:01:38 UTC
*** Bug 144499 has been marked as a duplicate of this bug. ***
Comment 15 Buovjaga 2021-09-20 06:23:37 UTC
(In reply to Rizal Muttaqin from comment #13)
> (In reply to Jan-Marek Glogowski from comment #9)
> > FWIW: the patch also applies to 7.2.1. I somehow missed to backport it.
> > There was https://gerrit.libreoffice.org/c/core/+/122116, but too late :-(
> 
> So, any chance 7.2.1 will be patched? This bug affects many UI elements
> which make LibO barely usable in kf5.

Patching is up to distro packagers.
Comment 16 Xisco Faulí 2021-09-22 11:11:53 UTC
*** Bug 144655 has been marked as a duplicate of this bug. ***
Comment 17 Jan-Marek Glogowski 2021-09-26 22:13:47 UTC
In the end I reverted the whole patch to resolve bug 144585 for 7.2.2, if someone want's to pick up the final fix before the release. Hopefully we can find a better solution on master.
Comment 18 Mike Kaganski 2021-09-27 06:08:22 UTC
*** Bug 144742 has been marked as a duplicate of this bug. ***
Comment 19 Buovjaga 2021-09-27 08:12:28 UTC
*** Bug 144739 has been marked as a duplicate of this bug. ***
Comment 20 Jan-Marek Glogowski 2021-09-27 16:34:32 UTC
*** Bug 144441 has been marked as a duplicate of this bug. ***
Comment 21 Xisco Faulí 2021-10-04 09:51:56 UTC Comment hidden (obsolete)
Comment 22 Roman Kuznetsov 2021-10-04 17:42:50 UTC
*** Bug 144873 has been marked as a duplicate of this bug. ***
Comment 23 Andreas Säger 2021-10-04 17:53:04 UTC
(In reply to Xisco Faulí from comment #21)
> *** Bug 144872 has been marked as a duplicate of this bug. ***

That bug is not a duplicate of this one.
Comment 24 Mike Kaganski 2021-10-06 05:26:12 UTC
*** Bug 144956 has been marked as a duplicate of this bug. ***
Comment 25 V Stuart Foote 2021-10-06 11:37:33 UTC
per comment 17, fix caused bug 144585

reverted with https://gerrit.libreoffice.org/c/core/+/122356 for 7.2.3

reverted with https://gerrit.libreoffice.org/c/core/+/122449 as late for 7.2.2

but is still left in trunk/7.3.0
Comment 26 Julien Nabet 2021-10-06 19:13:53 UTC
*** Bug 144857 has been marked as a duplicate of this bug. ***
Comment 27 Julien Nabet 2021-10-07 18:57:18 UTC
*** Bug 144974 has been marked as a duplicate of this bug. ***
Comment 28 Julien Nabet 2021-10-07 19:01:06 UTC
I know it's not a crash and specific to Linux/kde env but:
- it's a regression
- it makes LO unusable on KDE
- it has a lot of duplicates
I think this one requires an exception on bug triaging rules.
Comment 29 Mike Kaganski 2021-10-08 08:06:03 UTC
*** Bug 144993 has been marked as a duplicate of this bug. ***
Comment 30 giors_00 2021-10-08 08:22:34 UTC
(In reply to Mike Kaganski from comment #29)
> *** Bug 144993 has been marked as a duplicate of this bug. ***

Dropdown-menus are still unusable even in Libreoffice 7.3 alpha (kf5+wayland). And I have to confirm that libreoffice is quite unusable under kde-plasma+wayland (have to go back to gnome).
Comment 31 Julien Nabet 2021-10-08 11:12:03 UTC
Created attachment 175595 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I don't reproduce this but I noticed this log:
warn:legacy.osl:3273:3273:svtools/source/control/toolbarmenu.cxx:54: OSL_ASSERT: pWindow
with gtk3 (and I had similar with kf5 rendering).

I've got this if I do:
- View/User interface
- Tabbed

I don't have this with by default view/user interface.
Comment 32 Julien Nabet 2021-10-08 11:14:16 UTC
Caolán: I know you're more expert in gtk3 part and this one concerns more kde but would you have some time to take a look on https://bugs.documentfoundation.org/show_bug.cgi?id=144037#c31 with associated bt?
I mean perhaps fixing the pb of parent window at least for tab user interface may help a bit.
Comment 33 Caolán McNamara 2021-10-08 13:49:30 UTC
(In reply to Julien Nabet from comment #32)
> I mean perhaps fixing the pb of parent window at least for tab user
> interface may help a bit.

I don't think this has a bearing on the main problem, its used for "taskpanelist" which is kind of obscure I feel, https://gerrit.libreoffice.org/c/core/+/123258 will silence the warning nevertheless
Comment 34 Michael Weghorn 2021-10-12 09:58:41 UTC
(In reply to V Stuart Foote from comment #25)
> per comment 17, fix caused bug 144585
> 
> reverted with https://gerrit.libreoffice.org/c/core/+/122356 for 7.2.3
> 
> reverted with https://gerrit.libreoffice.org/c/core/+/122449 as late for
> 7.2.2
> 
> but is still left in trunk/7.3.0

To be exact, the issue left in master/7.3.0 is not the one described here, but the Wayland-specific bug 144585. The X11 case is fine with both, 7.2 (from 7.2.2 on) and on master.
See https://gerrit.libreoffice.org/c/core/+/122356 for more details.

Closing this bug again accordingly. I'll reopen tdf#144585 instead.
Comment 35 Robert Cabane 2021-10-18 17:58:36 UTC
Resolution confirmed with 7.2.2.
THANK YOU VERY MUCH ! DEEPLY !
Comment 36 phd 2021-11-18 20:07:50 UTC
*** Bug 145704 has been marked as a duplicate of this bug. ***