Bug 144098 - importing data with "trim spaces" option leads to crash of Calc
Summary: importing data with "trim spaces" option leads to crash of Calc
Status: RESOLVED DUPLICATE of bug 144106
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-26 08:20 UTC by kubbugrep
Modified: 2021-10-11 09:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kubbugrep 2021-08-26 08:20:15 UTC
Description:
Trying to import text/data like the one attached below via the "Edit" -> "Paste Special" -> "Paste Unformatted Text" or "Paste Special" menu using the "Text Import" window or "Use text import dialogue box" will reproducible lead to a crash of the application immediately after selecting the "Trim Spaces" option.

example data:
2021-08-26 16:35:13,252 fail2ban.filter         [469]: INFO    [sshd] Found 142.93.159.243 - 2021-08-26 16:35:12
2021-08-26 16:22:35,950 fail2ban.filter         [469]: INFO    [sshd] Found 210.179.33.108 - 2021-08-26 16:22:35


You can also find two of several example crash reports under the following URLs:
https://crashreport.libreoffice.org/stats/crash_details/83d0ec6b-8db5-47b4-8005-af327f91c4e3
https://crashreport.libreoffice.org/stats/crash_details/e6afa6fa-86bd-4df1-a89b-d0da2b07f49e

Steps to Reproduce:
1. copy example data given in the report above
2. open LibreOffice Calc
3. press Ctrl+Shift+V
4. "Paste Special" windows pops up
5. select "Use text import dialogue box" option and press OK
6. "Text Import"  window pops up
7. select "Trim spaces" option
-> application crash

If the "Trim spaces" option is active per default, application crash will occure already after step 5.

Actual Results:
application crash

Expected Results:
no application crash


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: de
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 m.a.riosv 2021-08-26 08:46:51 UTC
No crash for me with
Version: 7.2.0.4 (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 4; OS: Windows 10.0 Build 21390; UI render: Skia/Vulkan; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: CL

Please test with a clean profile, Menu/Help/Restart in Safe Mode
Comment 2 [REDACTED] 2021-08-26 12:07:03 UTC
No repro

Version: 7.2.0.4 / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 3 kubbugrep 2021-09-27 06:24:22 UTC
Bug still persists in version 7.2.1.2 (Build: 87b77fad49947c1441b67c559c339af8f3517e22)

A little bit in depth research showed, that this bug occurs only if the following two "Separator Options" (with "Separated by" enabled) are selected simultanously:
"Space" and "Trim spaces"

The crash can be prevented by additionally enabling the option "Merge delimiters".

User Profile Reset: Yes
Reproducible: Always

[Information automatically included from LibreOffice]
Locale: de
Module: SpreadsheetDocument
OS: Windows 10
OS is 64bit: Yes
Comment 4 Ming Hua 2021-09-27 10:06:59 UTC
This look a lot like bug 144106 which has been fixed in both 7.3/master and 7.2 branches.

(In reply to kubbugrep from comment #3)
> Bug still persists in version 7.2.1.2 (Build:
> 87b77fad49947c1441b67c559c339af8f3517e22)
kubbugrep, would you please test with 7.2.2 RC1 available at https://www.libreoffice.org/download/download/?version=7.2.2 ?  Thanks.
Comment 5 Xisco Faulí 2021-09-27 10:09:48 UTC
Thanks for reporting this issue.
This is a duplicate of bug 144106 and the fix will be available in LibreOffice 7.2.2

*** This bug has been marked as a duplicate of bug 144106 ***
Comment 6 kubbugrep 2021-10-11 09:31:38 UTC
(In reply to Ming Hua from comment #4)
> This look a lot like bug 144106 which has been fixed in both 7.3/master and
> 7.2 branches.
> 
> (In reply to kubbugrep from comment #3)
> > Bug still persists in version 7.2.1.2 (Build:
> > 87b77fad49947c1441b67c559c339af8f3517e22)
> kubbugrep, would you please test with 7.2.2 RC1 available at
> https://www.libreoffice.org/download/download/?version=7.2.2 ?  Thanks.

Problems seems to be solved in 7.2.2
Version: 7.2.2.2 (x64) / LibreOffice Community
Build ID: 02b2acce88a210515b4a5bb2e46cbfb63fe97d56
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

p.s. Sorry for the late reply.