Bug 144120 - Flickering extended tooltip text on “Select X.509 Certificate” dialogue box and unable to sign the document on mac version LibreOffice 7.2
Summary: Flickering extended tooltip text on “Select X.509 Certificate” dialogue box a...
Status: RESOLVED DUPLICATE of bug 105433
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-27 08:14 UTC by TseRigs
Modified: 2022-06-06 23:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
recorded video clip of flickering issue on LibreOffice 7.2 (308.25 KB, video/quicktime)
2021-08-27 08:19 UTC, TseRigs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description TseRigs 2021-08-27 08:14:10 UTC
Description:
Flickering text on “Select X.509 Certificate” dialogue box and unable to select the certificate to sign the document. I got this problem on all applications of LibreOffice 7.2.0.4

Steps to Reproduce:
1. Created new document and saved it.
2. Menu: File > Digital Signatures > Digital Signatures... 
3. Sign Documents... 

Actual Results:
Flickering text with mouse pointer. Unable to sign the document because it shows only empty dialogue box. 

Expected Results:
No flickering text. Able to select the certificate to use for signing document.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.2.0.4 / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded
Comment 1 TseRigs 2021-08-27 08:19:55 UTC
Created attachment 174572 [details]
recorded video clip of flickering issue on LibreOffice 7.2
Comment 2 steve 2021-08-27 11:57:00 UTC
Do not reproduce flickering in the Digital Signatures dialog. Using 7.2.0.4 on macOS 11.5.2. WHich macOS are you using?
Comment 3 Alex Thurgood 2021-08-27 14:04:11 UTC
Confirming with

Version: 7.2.0.4 / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
Calc: threaded

The flickering text for me is the extended tooltip text that appears when the user clicks on the "Sign the Document" button, and then moves the mouse over the X509 certificate selection area. 

Even if no certificate is present in the list, the flickering tooltip text appears and follows the mouse cursor around.
Comment 4 Alex Thurgood 2021-08-27 14:10:49 UTC
@TseRigs : 

The inability to find digital certificates and sign any document digitally on macOS is related to bug 115538
Comment 5 steve 2021-08-30 09:10:32 UTC
@Alex: I think TseRigs was specifically referencing "Select X.509 Certificate" not OpenPGP.
Comment 6 Aron Budea 2022-06-06 23:12:25 UTC
Let's mark this as duplicate of bug 105433.

*** This bug has been marked as a duplicate of bug 105433 ***