Bug 144133 - "Could not find Help page (404)" for help button in value dialog in Expert Configuration
Summary: "Could not find Help page (404)" for help button in value dialog in Expert Co...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Rafael Lima
URL:
Whiteboard: target:7.4.0
Keywords:
Depends on:
Blocks: Help-Link
  Show dependency treegraph
 
Reported: 2021-08-27 16:50 UTC by Regina Henschel
Modified: 2022-01-03 14:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2021-08-27 16:50:51 UTC
Start LibreOffice. Tools > Options > LibreOffice > Advanced. Click 'Open Expert Configuration'. Search for term GreekCharStyle. Double-click the found item. In that dialog click on Help button.

The text on the 404-page is:

That is an error. Possible causes are:

    The page does not exist and must be created.

    The page exists, but the Help ID is wrong or missing.

Use the Module, Contents, Index and Search selectors to find the right page.

The following data could be helpful in locating the error:

Help ID: cui/ui/aboutconfigvaluedialog/dialog-action_area1
Comment 1 Rafael Lima 2021-08-30 11:49:44 UTC
Hi Regina! Thanks for reporting this issue.

Actually, this problem helps with any option you select in the "Expert Configuration" dialog. The reason being that the Help button is contextualized by the tags they're located inside the ui file.

Considering this, the fix would be to add the HID to the following page:
https://help.libreoffice.org/7.2/en-US/text/shared/optionen/expertconfig.html

Hence when the user clicks Help in the dialog you mentioned, this page will be displayed.
Comment 2 Rafael Lima 2021-08-30 11:50:44 UTC
Typo in my previous message:

Actually, this problem happens with any option you select in the "Expert Configuration" dialog.
Comment 3 Commit Notification 2021-12-10 21:23:33 UTC
Rafael Lima committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/6fa6b45d603d01cb30549cdf9d1c56fa9376aa67

tdf#144133 Fix help target for Expert Config Edit dialog