Bug 144174 - LibreOffice 7.2.1.1 (64 bit) won't open on most of our systems
Summary: LibreOffice 7.2.1.1 (64 bit) won't open on most of our systems
Status: RESOLVED DUPLICATE of bug 144598
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.1.1 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-30 09:41 UTC by James Buton
Modified: 2021-11-17 13:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Buton 2021-08-30 09:41:53 UTC
Description:
We updated all our systems to LibreOffice v7.2.1.1. The installers worked as expected on all systems. All older system could not open LibreOffice. There was no background task hanging. Hardware acceleration/Open CL & GL are disabled. Several 'reboot and retry' cycles did not fix the problem. The only thing which worked was to roll-back to v7.2.0.4 (64 bit) which immediately resolved the issue. Only one computer we have can successfully run 7.2.1.1. It happens to be a new gaming machine, with UEFI booting. We can't ascertain what this machine has that resolves the issue. All the others machines are not able to run 7.2.1.1 (x64). We can't figure-out why the other machines will not allow LibreOffice to start up after a successful installation. LibreOffice v7.2.1.1 displays in the Control Panel as normal, and uninstalls successfully.

Steps to Reproduce:
1. Install LO 7.2.1.1 (64 bit) on a system
2. Try to start LibreOffice normally
3. Try to start LibreOffice in Safe Mode

Actual Results:
There's a windows mouse/cursor "thinking" icon as it tries to launch LO, and the nothing occurs. Rolling back to a previous version always fixes this issue. We feel it has to be something in this latest pre-release version.  

Expected Results:
We would have expected LibreOffice to open and run normally


Reproducible: Always


User Profile Reset: Yes



Additional Info:
LibreOffice should have opened/started normally when selecting the LibreOffice shortcut.
Comment 1 Xisco Faulí 2021-08-31 16:53:25 UTC
it works fine for me in

Version: 7.2.1.1 (x86) / LibreOffice Community
Build ID: 3cfc32d9754d2d239bd8ce2941029c12873010c1
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win
Locale: ar-DZ (es_ES); UI: es-ES
Calc: threaded

did you get it from https://dev-builds.libreoffice.org/pre-releases/win/x86_64/ ?
Comment 2 Roman Kuznetsov 2021-08-31 17:15:33 UTC
James, what Windows version do you use?
Comment 3 James Buton 2021-08-31 19:17:20 UTC
Dear Roman Kuznetsov, All systems we're using are Windows 10 (64 bit) Home. It happens to be the only system is *does* run on is Windows 10 Pro. Be they Home or Pro, the version is 21H1 (build 19043.1165)

We were wondering; could it be to do with a Microsoft Visual C++ redistributable package issue? Does LibreOffice require this to work? If so, which pack is crucial? Each machine has a few of these, but different ones per machine.
Comment 4 James Buton 2021-08-31 19:18:30 UTC
Version: 7.2.1.1 (x64) / LibreOffice Community
Build ID: 3cfc32d9754d2d239bd8ce2941029c12873010c1
CPU threads: 12; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-GB
Calc: CL
Comment 5 QA Administrators 2021-09-01 04:19:06 UTC Comment hidden (obsolete)
Comment 6 stragu 2021-09-04 00:59:32 UTC
Can't reproduce with:

Version: 7.2.1.1 (x64) / LibreOffice Community
Build ID: 3cfc32d9754d2d239bd8ce2941029c12873010c1
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: default; VCL: win
Locale: en-AU (en_AU); UI: en-US
Calc: threaded
Comment 7 Ming Hua 2021-09-04 01:12:42 UTC
(In reply to James Buton from comment #3)
> We were wondering; could it be to do with a Microsoft Visual C++
> redistributable package issue? Does LibreOffice require this to work?
Yes LibreOffice does require MS Visual C++ redistributable libraries.  But the official MSI installer for Windows should check them and install them automatically if necessary.  So if you were installing using the MSI installer, it shouldn't be a problem.
Comment 8 Ming Hua 2021-09-04 01:22:38 UTC
One more note:

(In reply to James Buton from comment #0)
> Hardware acceleration/Open CL & GL are disabled.

(In reply to James Buton from comment #4)
> CPU threads: 12; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL:
> win
This "UI Render: Skia/Raster" means your hardware acceleration using the new Skia (replacing OpenGL since 7.0 on Windows) is turned on.  To turn it off, go to Tools > Options > LibreOffice > View > Graphics Output, and uncheck "Use Skia for all rendering".

However I doubt this is the problem either, since there shouldn't be anything different about Skia support between 7.2.0.4 and 7.2.1.1.
Comment 9 stragu 2021-09-04 08:52:02 UTC
@James, could you please try the most recent build?
Comment 10 Eike Rathke 2021-09-12 22:52:29 UTC
This might be related to Skia and the video driver in use, see bug 144434 and bug 143152.
Comment 11 JO3EMC 2021-09-13 03:55:48 UTC
(In reply to Eike Rathke from comment #10)
> This might be related to Skia and the video driver in use, see bug 144434
> and bug 143152.

I don't know what's going on... but I've found that Bug 143152 has been resolved in a recent nightly build (in my environment).

By the way, this problem in 7.2.1 is not reproduced in my environment.

Version: 7.2.1.1 (x64) / LibreOffice Community
Build ID: 3cfc32d9754d2d239bd8ce2941029c12873010c1
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: ja-JP (ja_JP); UI: ja-JP
Calc: CL

The same is true for 7.2.1.2.
Comment 12 James Buton 2021-09-13 19:11:33 UTC
Yes! I have found that the newer RC version of LibreOffice has resolved this issue across all our systems that could not run 7.2.1.1. Version 7.2.1.2 runs as normal. 

There's defiantly something up with 7.2.1.1 and the latest RC proves it. 

We even tested it by rolling back the version to 7.2.1.1 and the same problem happened! Put in 7.2.1.2 and it's fixed.
Comment 13 James Buton 2021-09-13 19:11:56 UTC Comment hidden (obsolete)
Comment 14 James Buton 2021-09-13 19:12:40 UTC
I have found that the newer RC version of LibreOffice has resolved this issue across all our systems that could not run 7.2.1.1. Version 7.2.1.2 runs as normal. 

There's defiantly something up with 7.2.1.1 and the latest RC proves it. 

We tested this by rolling back to version 7.2.1.1 and the same problem happened! Put in 7.2.1.2 and it's fixed.
Comment 15 Roman Kuznetsov 2021-09-13 20:03:08 UTC
So, let's close this one as WFM
Comment 16 Luboš Luňák 2021-09-20 11:01:28 UTC

*** This bug has been marked as a duplicate of bug 144598 ***