Bug 144193 - CRASH: importing document (gtk3)
Summary: CRASH: importing document (gtk3)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.3.0
Keywords: bibisected, bisected, haveBacktrace, regression
: 144290 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-08-30 16:08 UTC by Xisco Faulí
Modified: 2021-09-06 08:38 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (5.37 KB, text/plain)
2021-08-30 20:56 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2021-08-30 16:08:24 UTC
Steps to reproduce:
1. Open attachment 68219 [details] from bug 55736

-> Crash

Reproduced in

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 6669c1a06bcc3ce31c9c17c714fdf2c2e0e25360
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2021-08-30 16:09:23 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=426930d0c4bd6f782a04a92e8a36e92cd65e186f

author	Noel Grandin <noelgrandin@gmail.com>	2021-08-28 08:35:29 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2021-08-28 15:13:20 +0200
commit	426930d0c4bd6f782a04a92e8a36e92cd65e186f (patch)
tree	18a08e3cfe139e6e780a246e68cc1c4216b7db78
parent	69e0567e118f00f299b6aac645c249521eb0629f (diff)
speedup dynamic_cast to SwTextFrame

Bisected with: bibisect-linux64-7.3

Adding Cc: to Noel Grandin
Comment 2 Julien Nabet 2021-08-30 20:56:35 UTC
Created attachment 174651 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce the crash.
I noticed that I don't reproduce this each time but 50% of time.
Comment 3 Xisco Faulí 2021-09-02 14:31:22 UTC
Still reproducible in

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: c085fc7cd335e3ea50a6bbaedf2f6e8cffadf559
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 4 Commit Notification 2021-09-04 11:36:52 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/dd10990aeb7ae2c3afb0c06a3d7b120101cd93c0

tdf#144193 fix import crash

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2021-09-06 08:16:56 UTC
*** Bug 144290 has been marked as a duplicate of this bug. ***