Bug 144197 - Overlapping images on DOCX/DOC export
Summary: Overlapping images on DOCX/DOC export
Status: RESOLVED DUPLICATE of bug 112313
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-30 20:03 UTC by Telesto
Modified: 2021-08-31 09:09 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
The example file and its docx version in current master (777.81 KB, image/png)
2021-08-31 09:09 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-08-30 20:03:08 UTC
Description:
Overlapping images on DOCX/DOC export

Steps to Reproduce:
1. Open attachment 164384 [details] (bug 135851)
2. Save as DOCX or DOC
3. File reload


Actual Results:
Bottom image overlap

Expected Results:
Same layout as ODT


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 05ff3d67d0e2e436406786c949eb7cfca107ba33
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

and in
4.4.7.2

Versie: 4.2.0.4 
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

not in
Versie: 4.1.0.4 
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28
Comment 1 NISZ LibreOffice Team 2021-08-31 09:09:07 UTC
Created attachment 174658 [details]
The example file and its docx version in current master

Layout changes in:

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: d350a1364a1c34b96d00f2f716c44882b7b57fe9
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL

Looks similar in Word 2019 as well.

I think this is quite similar to bug 112313 - in ODT there can be more space between the image and the margin to not wrap the text (the empty paragraphs this case) around the image, while in DOCX / Word less space is enough for the text to be wrapped.
Comment 2 NISZ LibreOffice Team 2021-08-31 09:09:45 UTC
Marking as duplicate for now.

*** This bug has been marked as a duplicate of bug 112313 ***