Bug 144295 - Shaded box covers menu and icons
Summary: Shaded box covers menu and icons
Status: RESOLVED DUPLICATE of bug 131023
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-04 18:21 UTC by weldabar
Modified: 2022-09-08 05:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Partially Obscured (46.96 KB, image/png)
2021-09-04 18:27 UTC, weldabar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description weldabar 2021-09-04 18:21:35 UTC
Description:
When dragging the application window wider, a shaded box starts in the top-left corner of the application covering the menu and icons. The wider the application window, the larger the box. When the application is in full screen the box extends just past the 'help' menu item. This makes the menu difficult to see.

Steps to Reproduce:
1. Start LibreOffice (not in full-screen mode)
2. drag the application window wider, or just press full-screen box
3. notice the grey-filled rectangle covering the menu and icons

Actual Results:
The wider the window, the wider the box covering the menu and icons.
I tested with LibreOffice, Writer, and Calc.

Expected Results:
There should be no shaded box obscuring the menu.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
I think this started with 7.2.0.4, but am not certain. I don't think it did this for 7.1.4.x.

Version: 7.2.0.4 (x64)
Environment: CPU threads 4, OS: Windows 10.0 Build 19043.
User Interface: UI render: Skia/Raster; VLC: win
Locale: en-US
Comment 1 weldabar 2021-09-04 18:27:34 UTC
Created attachment 174777 [details]
Partially Obscured

Window not yet full-screen-width.
Comment 2 yellowplane 2021-09-16 16:31:56 UTC
No reproduction in 

Version: 7.3.0.0.alpha0+ (x86) / LibreOffice Community
Build ID: d5e55d204b71710eb5eb5d2c683dd6698626df3c
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: en-GB (en_US); UI: en-US
Calc: threaded
Comment 3 weldabar 2021-09-19 15:18:51 UTC
In safe mode the problem disappears until I apply a theme.
(options > LibreOffice > Personalization > Preinstalled Theme )

Conversely, back in my original user profile, the problem goes away if I remove any theme.

I also want to emphasize that this problem only starts to appear when the application is > ~75% screen width, and fully there at full screen width.
Comment 4 Buovjaga 2022-09-07 13:16:35 UTC
This looks familiar, but I am unable to find an earlier report. Are you using display scaling?
Comment 5 weldabar 2022-09-07 22:35:36 UTC
Yes.

Windows > settings > display > scale and layout > change the size of text, aps, and other items > 175%

I set it back to 100% just now, and it makes the problem worse because it's easier to hit the size threshold where the problem occurs. It is most noticeable with a dark theme. The shaded box is light-gray. With a dark them the text is white. Light-gray over white makes the text unreadable. I've learned to live with it by using a light theme or no theme so that the text is black.
Comment 6 QA Administrators 2022-09-08 05:07:19 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2022-09-08 05:36:38 UTC
Rizmut found the earlier report.

*** This bug has been marked as a duplicate of bug 131023 ***