Bug 144316 - When opening ODS files that have hidden columns/rows, the columns/rows randomly un-hide and need to be hidden again.
Summary: When opening ODS files that have hidden columns/rows, the columns/rows random...
Status: RESOLVED DUPLICATE of bug 128895
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.5.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-05 17:20 UTC by Kain Yusanagi
Modified: 2021-09-06 08:41 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kain Yusanagi 2021-09-05 17:20:48 UTC
Description:
Pretty much exactly what the summary says; when opening (FILEOPEN for key words) an ODS file in LibreOffice Calc that has hidden columns/rows saved as hidden, they randomly decide to un-hide, but chooses a sheet at random to do this. It won't happen while you have the document open for any length of time, only on re-opening it after closing, for whatever reason. I like my spreadsheets to be nice and orderly, presenting only the information I have entered and thus being easy to scroll around within the bounds of, so this is rather irritating.

Happens regardless of being in Safe Mode or not (had it actively happen when launching in Safe Mode as a test).

Unsure if OpenGL is in use, as the OpenGL documentation on wiki indicates a checkbox that doesn't seem to exist as of version 7.1.5.2; the OpenCL setting just a bit further down is checked, but that says that it's merely "available for use", so unsure if that's the same.

Steps to Reproduce:
1.Create an ODS file in Calc.
2.Enter information into the sheet on multiple tabs, and then hide all extra rows/columns.
3.Save and quit, then re-open.

Actual Results:
Sometimes, works as expected; no issue. Sometimes, works as described; hidden rows/columns break out of hiding on various sheets, and need to be re-hidden.

Expected Results:
It to never randomly un-hide columns/rows on opening a saved file that has them hidden.


Reproducible: Sometimes


User Profile Reset: Yes



Additional Info:
Version: 7.1.5.2 (x64) / LibreOffice Community
Build ID: 85f04e9f809797b8199d13c421bd8a2b025d52b5
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: en-CA (en_CA); UI: en-GB
Calc: CL
Comment 1 Timur 2021-09-06 08:41:54 UTC
Seems duplicate, please search before reporting.

*** This bug has been marked as a duplicate of bug 128895 ***