Bug 144332 - [LOCALHELP] Write Help page for ACCESSIBILITY CHECK
Summary: [LOCALHELP] Write Help page for ACCESSIBILITY CHECK
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All All
: medium normal
Assignee: Olivier Hallot
URL:
Whiteboard: target:7.3.0 target:7.4.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures Help-Link
  Show dependency treegraph
 
Reported: 2021-09-06 15:23 UTC by Olivier Hallot
Modified: 2022-08-02 06:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2021-09-06 15:23:03 UTC
Missing Accessibility Check Help page 

The following data could be helpful in locating the error:

Help ID: svx/ui/accessibilitycheckdialog/dialogButtons

https://tomazvajngerl.blogspot.com/2020/01/accessibility-checker-and-support-for.html

https://wiki.documentfoundation.org/ReleaseNotes/7.0#Accessibility_improvements
Comment 1 Commit Notification 2021-09-07 12:04:03 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/e02e75de71eed2d22a4ad4bb18bbfb1f60aa5480

tdf#144332 Add Help page for Accessibility Check Tool
Comment 2 stragu 2021-09-16 03:15:46 UTC
Confirmed that the button in the accessiblity tool does not lead to a relevant help page.

It goes to: https://help.libreoffice.org/7.3/en-US/text/shared/05/err_html.html?System=WIN&DbPAR=WRITER&HID=svx/ui/accessibilitycheckdialog/help

Version: 7.2.1.1 (x64) / LibreOffice Community
Build ID: 3cfc32d9754d2d239bd8ce2941029c12873010c1
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: default; VCL: win
Locale: en-AU (en_AU); UI: en-US
Calc: threaded
Comment 4 Commit Notification 2021-09-16 10:04:54 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/446fbc68aaf1ddc03e3b8c176d943c5f5ca09ade

tdf#144332 fix bookmark typo + refactors
Comment 5 Dieter 2021-11-19 08:13:47 UTC
(In reply to stragu from comment #2)
> Confirmed that the button in the accessiblity tool does not lead to a
> relevant help page.
> 
> It goes to:
> https://help.libreoffice.org/7.3/en-US/text/shared/05/err_html.
> html?System=WIN&DbPAR=WRITER&HID=svx/ui/accessibilitycheckdialog/help

Still valid with

Version: 7.3.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 7b8f630db30ee0066a9f4b6e540368d2fcad7fa8
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Current target: https://help.libreoffice.org/7.3/en-GB/text/shared/05/err_html.html?System=WIN&DbPAR=WRITER&HID=svx/ui/accessibilitycheckdialog/dialogButtons
Comment 6 Commit Notification 2022-01-03 16:36:27 UTC
Rafael Lima committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/b79052ed393b4e006658816c7e611b7a6ef6b2f6

tdf#144332 Fix HID for Accessibility Check
Comment 7 Dieter 2022-06-01 13:48:38 UTC
We have now page "Accessibility Check" in 7.4 [1] and also in 7.3 [2].

Link from Accessibility check dialog to help page works in
Version: 7.4.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 5423dfb8549743bd5045b6e3b1ebad7980e62965
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

but not in
Version: 7.3.4.1 (x64) / LibreOffice Community
Build ID: 13668373362b52f6e3ebcaaecb031bd59a3ac66b
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL


[1] https://help.libreoffice.org/7.4/en-GB/text/swriter/01/accessibility_check.html?System=WIN&DbPAR=WRITER&HID=svx/ui/accessibilitycheckdialog/dialogButtons#bm_id541630940172937

[2] https://help.libreoffice.org/7.3/en-GB/text/swriter/01/accessibility_check.html?System=WIN&DbPAR=WRITER&HID=svx/ui/accessibilitycheckdialog/dialogButtons#bm_id541630940172937
Comment 8 Dieter 2022-08-02 06:18:21 UTC
(In reply to Dieter from comment #7)
> Link from Accessibility check dialog to help page still doesn't work in LO 7.3, but since this is not the core topic of this bug report, let's change it to VERIFIED.

Olivier, Rafael, thank you for fixing it!