Bug 144333 - [CRASH] OpenGL transitions crash Impress since LibreOffice 7.2
Summary: [CRASH] OpenGL transitions crash Impress since LibreOffice 7.2
Status: RESOLVED DUPLICATE of bug 144289
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-06 15:37 UTC by Rafael Lima
Modified: 2021-09-06 18:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample File (120.75 KB, application/vnd.oasis.opendocument.presentation)
2021-09-06 15:37 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2021-09-06 15:37:30 UTC
Created attachment 174824 [details]
Sample File

Since LO 7.2.0.4 OpenGl transitions stopped working. I am using the kf5 plugin.

Consider the sample file attached to this bug report (it is an actual snippet of one of my classes). The first slide has a non-OpenGl transition and the other slides have the Fade OpenGl transition.

If you open the file in LO 7.1 it will work as expected. Press F5 to start presentation and all slides will be shown and transitions will work.

If you open the file in LO 7.2 and press F5 to start the presentation, the first slide will be shown (because it does not have a OpenGl transition). But when you go to the second slide (the one with an OpenGl transition), LibreOffice will crash immediately.

I tried enabling and disabling "use hardware acceleration" in Tools - Options - View, but crashes continued happening.

CRASHES IN:
Version: 7.2.0.4 / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 16; OS: Linux 5.11; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: threaded

WORKS IN:
Version: 7.1.6.2 / LibreOffice Community
Build ID: 10(Build:2)
CPU threads: 16; OS: Linux 5.11; UI render: default; VCL: kf5
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Ubuntu package version: 1:7.1.6~rc2-0ubuntu0.21.04.1~lo1
Calc: threaded
Comment 1 m.a.riosv 2021-09-06 15:45:14 UTC
No issue with
Version: 7.2.0.4 (x64) / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 4; OS: Windows 10.0 Build 21390; UI render: Skia/Vulkan; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: CL
Comment 2 Xisco Faulí 2021-09-06 16:05:33 UTC
it looks like a duplicate of bug 144289.
Could you please try with a recent daily build?

*** This bug has been marked as a duplicate of bug 144289 ***
Comment 3 Rafael Lima 2021-09-06 18:04:46 UTC
(In reply to Xisco Faulí from comment #2)
> it looks like a duplicate of bug 144289.
> Could you please try with a recent daily build?

Hi Xisco, I have just downloaded the latest build of LO 7.3 alpha and the transitions worked under KF5.

I noticed that the patch for Bug 144289 was cherry picked for LO 7.2.1. I'll keep an eye when it's released to see if the bug really disappeared.

This is the DEV build on which I ran the tests:
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 4cd3ce9848aa039b8d443a1257d1298231680b01
CPU threads: 16; OS: Linux 5.11; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-09-06_04:39:11
Calc: threaded